bootloader: ATmega8L - 8PU

Hi, I'm with a problem when I go burn the bootloarder in ATmega8L - 8PU.
I use Windows 10 and IDE 1.6.8, the plataforma is the Arduino UNO and the programam is Arduino as ISP.

The messenger that it's printing is:

avrdude: Expected signature for ATmega8 is 1E 93 07
** Double check chip, or use -F to override this check.**
Encontrado um microcontrolador errado. Você selecionou a placa correta a partir do menu Ferramentas > Placa?

But I have total certainty that my microcontroller is ATmega8L - 8PU

For the ATmega8, 8A, 8L, the signature bytes are:

  1. 0x000: 0x1E (indicates manufactured by Atmel).
  2. 0x001: 0x93 (indicates 8KB Flash memory).
  3. 0x002: 0x07 (indicates ATmega8A device).

What signature bytes are being read instead?

Turn on verbose upload in settings so you can see what signature it's getting back. Most likely it will be reporting 0x000000 as the signature, which indicates that wires are connected improperly, or you have already programmed the low fuse such that it won't have a usable clock signal with the hardware you have connected to it. This usually happens if you set it to use an external crystal, but said crystal is not properly connected, or you screwed up and set it to use an external clock source when you meant external crystal.

I've got the connections are connected. I'm having a doubt also in relation to the crystal osciliador is:
The ATmega8 uses 16MHz
The ATmega8A also tulzia 16Mhz
and ATMEGA8L utilzia 8MHz
(According to the data sheet)

DrAzzy:
Turn on verbose upload in settings so you can see what signature it's getting back.

This is a vital step in the process - you should do this. Leave it on if you like using weird parts like the atmega8, it's very valuable information.

Well you have the chip, what speed crystal is it connected to?
If it doesn't have a crystal, you need to select a configuration that uses the internal RC oscillator when you do burn bootloader - otherwise it will brick the chip (and you'll need to connect either a crystal or an external clock signal just to be able to talk to it and set it back to using the internal RC)

Initially I used a crystal oscillator 8MHz, but results in sync failure. So I started to put a 16MHz oscillator, and is now appearing that message.
what is "verbose"? I searched the internet but found nothing related.

In ide settings check the verbose upload box.

It makes it show all the output, and this is very valuable for upload and bootloading issues

When you say you used an oscillator, you are talking about the physical piece of hardware right? Or just the ide setting? Ide setting needs to match the hardware.

Sorry about the delay, my program is in Portuguese and have been searching about it. Thanks the same way.

Anyway, I activated and appears this data:

avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Users\Gabriel Soares\Downloads\arduino-nightly-windows\arduino-nightly\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM3
Using Programmer : stk500v1
Overriding Baud Rate : 19200
AVR Part : ATmega8
Chip Erase delay : 10000 us
PAGEL : PD7
BS2 : PC2
RESET disposition : dedicated
RETRY pulse : SCK
serial program mode : yes
parallel program mode : yes
Timeout : 200
StabDelay : 100
CmdexeDelay : 25
SyncLoops : 32
ByteDelay : 0
PollIndex : 3
PollValue : 0x53
Memory Detail :

Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


eeprom 4 20 128 0 no 512 4 0 9000 9000 0xff 0xff
flash 33 10 64 0 yes 8192 64 128 4500 4500 0xff 0x00
lfuse 0 0 0 0 no 1 0 0 2000 2000 0x00 0x00
hfuse 0 0 0 0 no 1 0 0 2000 2000 0x00 0x00
lock 0 0 0 0 no 1 0 0 2000 2000 0x00 0x00
calibration 0 0 0 0 no 4 0 0 0 0 0x00 0x00
signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

Programmer Type : STK500
Description : Atmel STK500 Version 1.x firmware
Hardware Version: 2
Firmware Version: 1.18
Topcard : Unknown
Vtarget : 0.0 V
Varef : 0.0 V
Oscillator : Off
SCK period : 0.1 us

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.02s

avrdude: Device signature = 0x000000 (retrying)

Reading | ################################################## | 100% 0.02s

avrdude: Device signature = 0x0000ff
avrdude: Expected signature for ATmega8 is 1E 93 07
Double check chip, or use -F to override this check.

avrdude done. Thank you.
Erro ao gravar o bootloader.

Wired wrong or you selected a configuration that used an external crystal and don’t have a crystal connected (or it is connected improperly) and did burn bootloader - this will softbrick the part, and you need to give it a clock signal to program it, even just to set it back to use the 8mhz internal oscillator so it will work without a crystal.

well, I need humility to admit that I made the wrong connections. I was using the ICSP connectors that are on the Arduino UNO, but decided now utilziar digital pins 13, 12, 11 and 10 and now is showing the following message:

"efuse" memory type not defined for part "ATmega8"
Erro ao gravar o bootloader.

Oh! Phew! So you haven’t soft-bricked it. You couldn’t have, burn bootloader via IDE fails on the Atmega8 because it doesn’t have efuses, but the IDE is hardcoded to try to write them.

Make sure you don’t have it set to use external crystal unless you’ve got one on the board.

Then attempt to burn bootloader with verbose upload enabled. The first line will be a command (different color from the output of AVRDude). It will be something like this (though almost every parameter will be different):

C:\Arduino\hardware\tools\avr/bin/avrdude -CF:\My Documents\Arduino\hardware\ATTinyCore\avr/avrdude.conf -v -pattiny4313 -carduino -PCOM1 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0xFF:m -Uhfuse:w:0x9F:m -Ulfuse:w:0xE4:m

Delete the -Uefuse:… part, open command prompt, and paste it in, and it should work. You can post the command before you send it and I’ll check it.

Guys, thank you for help. really helped me a lot and also taught me quite a lot. THANK YOU.

about the problem I have just mentioned, I followed this video and then the bootloader worked perfectly with the 16MHz oscillator.
The codes are going well, the only thing is that the program start in ATmega is slower than usual, but it is running normally.