bootloader corrupt?

Hello @ all :)

Yesterday I got my new Arduino Projects Pack from Makershed and tested it. Today it doesn't work anymore >_> I can't upload code (I'm getting this stk500_getsync(): no sync: resp 0x00) and the led on Pin 13 is not blinking if I reset my arduino Board... Is this a problem with the Hardware or can I fix the problem by re-burning the bootloader? :-? I got an Arduino Duemilanove with ATMega 328 and win 7 on my PC

thanks in advance :)

news: I tried to connect it on Mac osx 10.6 and Ubuntu Karmic Koala 9.10 but none of them are able to upload code... the TX and RX leds are flashing a little bit but just for some milliseconds :( edit: a little more information: I tried resetting before uploading sketches, I tried unpluging and repluging my board, reinstalled the driver like 3 times, tried every single usb port on my laptop and tried all on each of my 3 os's... edit2: this is what I'm getting when upload.verbose is set to true:

Binary sketch size: 896 bytes (of a 30720 byte maximum)
C:/***\hardware/tools/avr/bin/avrdude -CC:/***\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\\.\COM4 -b57600 -D -Uflash:w:C:/***\Local\Temp\build6698990034386006811.tmp\Blink.cpp.hex:i 


avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         System wide configuration file is "C:/***\hardware/tools/avr/etc/avrdude.conf"

         Using Port            : \\.\COM4
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 57600
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Recv: 
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51]   [20] 
avrdude: Recv: 
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.

I cannot help I fear; however I am experiencing exactly the same issue as you describe.

My board was working fine for a couple of weeks; as of yesterday, it just doesn't work.

Do you reckon it is possible to re-burn the bootloader then?

If that's a go-er, I'll do the same thing.

Thanks and good luck. Martin

I’m now trying to reburn the bootloader, using the arduino-avr method but getting errors (works just with -F option…) :frowning:
surprisingly it reads eFuse FF, hFuse FF and lFuse 07 (???) and bitlocker is 3F and not CF as mentioned here
trying it anyway, I’ll see if it works after that…
hope my chip is not dead :-/

edit: so now I tried something really crazy… tried to upload some code WITHOUT ANY ATmega chip… know what? exactly the same symptoms!! This is good because now it looks like it’s “just” the cpu which don’t work and not my board having a problem :stuck_out_tongue:
I’ll buy a new ATmega board, you can get one for 4$ which isn’t much :slight_smile: (btw it’s cheaper than buying an AVR programmer ^^)

Ah. Sounds like maybe I need to get a new chip as well (I think that's what you meant - when you said "I'll buy a ne ATmega board" - is it?).

If I get a new chip, am I likely to need to program it?

yeah I meant ATmega chip (cpu)^^ sry it depends on where you buy it, normally it should be in the description like on sparkfun I'm testing other ways to reburn the bootloader at the moment so if you wait a little more maybe I will find a solution :)

edit: tried every possible way to write a bootloader on my chip but it seems it's just broken (bad signature: 0xffffff) >:(

Thanks! I've just ordered a couple of chips from oomlout, which say "comes with arduino bootloader pre-installed".