Bootloader Flashing Headache

I'm attempting to upgrade an Arduino Extreme 2 board to an ATMega168 chip. I don't have the money (or the time) to get an AVRISP so I have to go the parallel route. I bought 2 ATMEGA168's, one extra in case something goes really sour.

I don't have easy access to components where I live so I don't have a male parallel port to solder my connections to, they're just going straight into the parallel port with the proper resistors laid out on a breadboard.

The arduino 0011 software returns an error immediately when trying to program with the parallel programmer, regardless if I'm trying to program a fresh 168 or my old 8. I've tried batch files with uisp commands and while they work, and the LED on pin 13 flickers, there are two major problems. One, I can't upload sketches afterwards. And two, if I use the --verify flag on the bootloader upload it returns massive amounts of errors. Obviously something ain't right.

Also could someone give me a concise explination or link to fuses and what's capable of setting them. In some posts it's said that uisp can't set fuses but AVRdude can, and the tutorial everyone seems to link to is long dead with no cache.

These are the links I've referenced:

"168 + parallel port + uisp + avrdude + boot loader"

"Bootloader on ATMEGA168"

Apparant fuse tutorial that's dead:

Thanks for your help!

Which bootloader are you trying to burn? You want to use the ATmega168 for NG bootloader.

When you use the --verify flag on the bootloader burning w/ uisp, do you get an error on every single byte or just a lot of them? If the latter, it might be because the connection is not very good.

If you set upload.verbose to true in your Arduino preferences file, and then try to burn the bootloader from the IDE, what output do you get?

I've tried both the bootloader found here ( and the specific NG version, both result in the same errors.

The verify errors are incredibly numerous and sequential. There are so many they scroll past the point of no return in the DOS window, meaning I can't scroll up to where I launched the batch file. I would dump this to a log file but I seem to have forgotten the command and am being lazy at the moment.

I turned on verbose in the Arduino preferences, here's a txt file of that output:

Any other ideas?

Thanks again!

It looks like nothing is getting written correctly. Are you sure your wiring is correct? Can you post a picture? Maybe you need a male parallel header to solder to?

Well let's talk about the diagram on the arduino site, is that like looking at the parallel port on my computer or the connections on the male header? I suppose they're the same...

If I mirror the connections, I get mostly the same results, the uisp dialog looks like it's flashing things but it's really not, the LED doesn't blink or dim. If I revert to plugging in my wires exactly like the diagram on the site, with the 220Ohm wire going into pin 41 in the upper left, I get the same dialogs and errors, but the LED flashes. Though I realize nothing is getting flashed any more than if the wires are plugged in improperly.

Just to clarify, the pin to the right of pin 1 on the ICSP header isn't supposed to be connected to anything?

I'm getting frustrated to the point of just buying a damn Diecimila and counting my 15 dollars towards two ATMEGA168s as a loss.