Bootloader issues on Uno R3

This is the latest post in a painful journey to try and revive my Arduino Uno R3...
The situation presents itself as follows:

  • Arduino stopped taking uploads after experimenting with Dallas 1-wire temperature sensor. Theories: Fried processor (unlikely in my opinion since sensor is a digital element) or damaged something in software.
  • Checked computer, cable, reinstalled IDE, drivers. No success.
  • Checked serial converter with loopback test. Did not work at first. Reflashed 16U2 using FLIP. Still no success. Removed 328P. Successful loopback. Tried again with processor inserted, sometimes works, sometimes doesn't. But 16U2 definitely OK.
  • Problem seems to lie in 328P. Therefore, tried to reburn using Mega as ISP. Successful burn, no errors. Bootloader chosen was Optiboot for 328. Solid LED_BUILTIN (was flashing with old code still uploaded). No success. Still not taking uploads (not_in_sync), TX only flashing at the end when error message is displayed. Loopbacks still behaving strangely (might be Layer 8 issue).

Does anyone have ideas on how I could proceed (checking if bootloader is installed etc.), if possible using other microcontrollers and not extra parts I'd need to order?

Try to replace 328P. Raw chip will need to upload the bootloader but you should know how to do it.

how I could proceed (checking if bootloader is installed etc.)

With ISP programmer, you can read-out the flash memory and fuse setting and compare with what is required.
Use the avrdude from CMD. The .HEX file form can differ so sometimes is easier to compare binary form. Use e.g. the bin2hex.exe to convert bootloader HEX to BIN.