bootloader lost ?!?!?!

Hi,
i’m using arduino on breadboard http://arduino.cc/en/Main/Standalone
it worked, but after some week of inactiviti, today i was going toupload some program BUT
when i linkded my atmega to PC and hit the reset button, the led on digital pin 13 hasn’t blinked… tryed to upload some code but still nothing… (programmer is not resonding) tested the tx/rx togheder and work.
Is possible my 2 atmega lost theyr bootloader? or are they broken? how can i test that (i have’t a AVR programmer >:( )

Same, I haven't touched it for 4 days, and I come back and I can't upload ****.

This is really annoying.

have you tryed with AVR? has it worked?

I am running Linux 10.04, so WinAVR + AVRstudio is unavailable.

If you mean avrdude, yes, I'm using that.

LED on pin 13 not blinking? hmmm With the Arduino Boot loader the LED is not going to blink unless you have the blinking sketch loaded. If you have the Ladyada boot loader then it would flash 3 times after you hit the reset button.

Anyway there are a few things you can check.

1- Measure the voltage at pin 1 ( Reset ) make sure it is not to ground when the button is not pressed. If it is, the chip is in a constant reset.

2- Make sure you have a pullup resistor on that pin.

3- Measure your supply voltage

4- if the circuit is in a breadboard, make sure the crystal and the 22Pf capacitors got good contact with the board.

Hope this helps

4- if the circuit is in a breadboard, make sure the crystal and the 22Pf capacitors got good contact with the board.

Also:

5- Make sure the crystal and caps are as close to the body of the chip and have as short of leads as possible.

6- Make sure the noise filtering caps are installed properly and are also as close to the chips leads as possible.

for blinking maybe i've confused the program with the boot loader... i've done some upload test and then put it apart, now i need it and they dosn't work...

  1. a led turn on, not really bright but worked last time (tested 2,5 V)
  2. pullup brow-black-orange-gold from USB +5V
  3. +5V from USB
  4. well.... the last time worked witout capacitors ::) testet with them on also but stll nothing... 5./6. ok, tested...

onother thing happen: touching the crystal LED turn on... Last upload program was turn on/off led when serial data arrive, but now seems it isn't there anymore :-(

i've found out... well i've recabled everything from scratch and now work... maybe somethimes atmega need to be moved ;D