Bootloader Not Burning/Chip not being detected/Fake chip?

Okay so we had ordered few samples of ATmega 328P-AU from Aliexpress, China but got ATmega 328PU-PH.

I tried searching for this online but didn't get any resource or mention in the datasheet.

Just for curiosity, I hooked it up in the circuit and tried boot-loading it using a Nano, it didn't work. Just a few blinks on Digital IO 13 when I power it up.

Now before I open a wrong product claim, wanted to ask :

Q) Is it an original chip or just a fake as there is no part no. available with the same name/package?

Q) Any way/method I can check this chip?

Hello there!

Most likely the AU and PH are the same chip, just a different packaging type maybe (bulk vs. tape and reel).

Can you post a schematic of the wiring you are using from your Nano to the 328? What program are you using on the Nano?

There seems to have been a recent outbreak of differently marked atmega328p's that people have been having issues with.

these chips are very cheap and worth buying from a reputable source.

I use for mine

Alas, chip labeling frequently isn't an exact match for actual part numbers, so I'm not sure that non-match labels mean anything...

I hooked it up in the circuit and tried boot-loading it using a Nano, it didn't work.

Would that be a circuit and bootloading setup/process that is "known to work" with real ATmega328p chips? Or a custom-designed new board, or something you just threw together? The -AU should be an SMT chip, right? Are the chips you got SMT as well, or DIPs? There is a lot that can go wrong in the "hook it up and program it" process (especially with SMT chips.)

There are now some chips from china that are "somewhat" Atmel compatible - the LGT8F328 from Logic Green. I'm not sure if they use the same ISP programming method as Atmel chips, though.

Apparently the new chip markings are due to the Microchip acquisition, to bring the markings into sync with the rest of Microchip's products.

I have corrupted the bootloader in LGT8F328P LQFP32 miniEVB probably
I have one more functional item.
Please, let me know how to upload the bootloader again?