bootloader problems

Good evening,

I have been extremely frustrated over trying to burn a bootloader on two(2) separate atmega328p u chips. I have tried everything I could find in the Arduino forums, on the web and on Youtube. I keep getting the same error of wrong signature. I have not tried a separate dedicated programmer due to the cost, I have been using two uno boards. I don’t want to give up on these chips but I really want to move on with my project.

I broke down and purchased an Uno with a removable chip for 13.00 from amazon tonight to complete my project.

Do both the UNO boards not work or one is not working? If one is working, then you should try to burn the bootloader of second using it.

…Arnav

Please do this:

  • (In the Arduino IDE) File > Preferences
  • Check the checkbox next to “Show verbose output during: upload”.
  • Click the “OK” button.
  • Tools > Burn Bootloader
  • After the Burn Bootloader process fails, you’ll see a button on the right side of the orange bar: “Copy error messages”. Click that button.
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply.
  • Press “Ctrl + V”. This will paste the Burn Bootloader output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

(deleted)

Are you trying to bootload atmega328p with oscillator or without oscillator please explain ? Which bootloader are trying to bootload is it 8MHz internal oscillator bootloader?

Hi All,
Thank you for your responses. First of all I bought two atmega328p u ic chips from Amazon. It was my understanding that they had no bootloader installed. The current Uno boards have the small surface mount chips for the atmega. I hooked up the ic chips in a breadboard and could not get them to accept the bootloader. I am glad that I purchased the new board last night. I put the chips in the new board, one at a time of course, and they both started to flash the blink sketch. I then tried to upload the minimum sketch and each chip took it. Then I uploaded the blink sketch again and it uploaded on both chips without errors. This tells me that either the boards were loaded already or the burnnig process worker.

Did you have a crystal or external oscillator when bootloading the chips on the breadboard? The fact that you can put the chip in the UNO board and successfully upload implies that you put the 16MHz bootloader on the chips, otherwise the serial communications baud rate would be incorrect. Once you have that bootloader on the chip, If you programmed the chips with a bootloader that uses an external clock signal, it then requires an external clock signal (either a crystal, resonator, or external oscillator), and will no longer respond to the ISP programmer without one.