Bootloader rebuild in windows returns no files

Hi all,

I tried to shorten the wait time in the bootloader of my Arduino Micro. I used an online tutorial.
Before starting the build I had to install WinAVR since I'm working with a Windows machine (x64).
After that I was able to run the makefile by entering the following commands when my path was pointing to the caterine folder. There are no errors, caterina.hex, .elf, .sym are build, but i'm not able to find them in the folder.
What am I doing wrong? Am I looking in the wrong folder? Please assist.

This what I did:

  • Open cmd.exe
  • go to C:\Program Files (x86)\Arduino\hardware\avr\bootloaders\caterina
  • make clean
  • make all

Result:

  • everything is beeing build, but the resulting file are nowhere to be found.

Can you post the output of make in your cmd.exe?

What OS is your computer running?
Did you install LUFA library?

Problem solved. Had to run the cmd.exe as administrator. Since the Arduino folder is a sub folder of Program files it needs authorization to write in those folders.
However I find it odd that there is no error displayed when permission is denied.

Sorry to bother you with this. But it might be help full for other who are experiencing the same issue.

I probably should make a new topic for this, but I'll give it a try. Maybe somebody can help me right away.
So I was able to rebuild the bootloader without any errors. I programmed it using my Arduino Uno. After a reset, it now stays in the boatloader. Which is verry odd since I only changed the bootloader timeout from 8000 to 3000. Otherwise nothing is changed.
What could gone wrong?
I don't see error, or any other thing that might indicate that an error has occured.

Here is promt of my build you can find at pastbin: http://pastebin.com/Rv09wBMX

I either have a admin cmd.exe on my desktop or just unzip arduino in my downloads folder so it is not installed in the program files folder.

So I concur that you need to create a new thread for your "device stays in bootloader" issue. But just a quick question here: how do you know your device is stuck in the bootloader? BTW, if I remember correctly, you will need some sketch in order for the bootloader to exit and jump to. Otherwise it probably jumps to the zero vector or somewhere the sketch should be but is empty that restarts the bootloader again.

In your new post, mention whether you were able to see two USB TTL devices on your device manager once you plug in your device. If you only see one (with bootloader in the name), then you just don't have a sketch.

Until you load the first sketch, it will continually stay in bootloader.

The permissions issue is a godawful mess. Depending on version of windows and settings, you may get errors, or it may blackhole the errors and not write the file, or write the file to the virtual store, so when you read it, you'll get a different file depending on whether you're admin or not. It's awful.

I install to C:/Arduino, not under program files.

I just used the default install path. Next time I install it, I'm going to edit the path.

As liudr and DrAzzy are suggesting the bootloader was successfully changed. I just had to reload my sketch in order to see the difference. Thank for the hint!

@luidr, how was I able to see that I was stuck in the bootloader, well the LED blinking pattern off course.

Hi
Can anyone please help with compiling leonardo bootloader.

Even i want to reduce time of the bootloader.

I am using GnuWin32 on windows 7.

when i enter 'make clean' command i get following error.

D:\ARDUINO\Bootloader_compile\hardware\arduino\bootloaders\caterina>make clean
The system cannot find the path specified.
The system cannot find the path specified.
ECHO is off.
-------- begin --------
ECHO is off.
Cleaning project:
rm -f Caterina.hex
process_begin: CreateProcess(NULL, rm -f Caterina.hex, ...) failed.
make (e=2): The system cannot find the file specified.
make: *** [clean_list] Error 2

Please help me with setting up make utility and paths.
thankyou.

You should have the arduino/hardware/avr/bin and arduino/hardware/avr/utils/bin in your path IIRC.

Thankyou soo much

Didnt know utils folder has make command for windows

after adding utils/bin to the path it worked

:smiley:

You're welcome. I went through the whole fuss to build caterina bootloader only to find out non-carefully written sketch could brick the device and I needed $5,000 for my own USB vendor ID, plus there won't be windows drivers for my device unless other magical things happen in the microsoft land.

What I did was just opening a cmd window and type path. There goes your answer.