Bootloading: OS X

Hey all. I've had two separate issues with properly bootloading from OS X.

First: my original Serial-USB converter did not work with the Atmel ISP. It was an IOGear:

I switched to a Keyspan and it worked nicely...on a different computer.

Since switching to my G4 Powerbook (12",1.33ghz, 2004 model), I have not been able to properly bootload a chip.

When trying to run the bootloader from a Terminal window, I received an error telling me that the UISP executable was not available in the /Tools directory. It was there however.

I copied all of the files in the booloader/tools folder into a new folder and redirected the BINDIR to that new folder and saved it as a new shell script.

This time around, upon running the new script, I received the proper notice that the firmware had loaded, the process ran succesfully, and closed itself out, exactly as it had done while bootloading from the first computer I succesfully booltoaded with.

It does not seem that the bootload worked, however, since I'm not getting the proper blinking LED on digital pin 13 when i try to reset it for programming, and I cannot succesfully download a program from Arduino.

One suggestion was that I might be overflowing the memory, but I'm not sure. Any thoughts?

Thanks in advance.