bossac.exe: extra arguments found

Hello Everyone,

I have had no problems connecting various other Arduino boards but I just got the DUE and am having a problem I am stuck at.

I followed the directions on installing the driver in the DUE documentation. I am running Windows 7 64-bit and the after the driver installed it shows up as: Arduino Due Programming Port (COM6) under the Ports section of Device Manager. I am using Arduino IDE 1.6.8 and have the board set as Arduino Due (Programming Port) and Port as COM6 (Arduino Due(Programming Port)).

I have a sketch that blinks lights that works fine on other Arduino boards, but I run Compile and Upload and it compiles fine, but I get this warning:

bossac.exe: extra arguments found
Try ‘bossac.exe -h’ or ‘bossac.exe --help’ for more information.

I don’t even see a place to choose arguments for this bossac.exe in the settings or what command line arguments the IDE is issuing so I am not sure what to do here.

Thank you for any help!

Hi Cody,

It is funny you should post EXACTLY the same error I just experienced!!

OK, until recently there were problems with Arduino IDE 1.6.6/7/8, hence most people stuck with IDE V1.6.5. Thankfully it seems they have fixed the problems and I have been tinkering around with 1.6.8 again, a few minutes ago I noticed an update to the SAM Core from 1.6.7 to 1.6.8. I have literally just installed it to be faced with the error you are seeing. I have just downloaded and installed IDE 1.6.9 (hourly build) and SAM Core 1.6.8 works properly, so it seems that you need to downgrade to SAM core 1.6.7 to fix your problem, or upgrade the IDE.



Hi Graham,

Thanks for that info, I will try that out right now! I just found the verbose settings for compiler and uploader messages and discovered where the problem is:

C:\Users\Admin\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.6.1-arduino/bossac.exe -i -d --port=COM6 -U false -e -w true -b C:\Users\Admin\AppData\Local\Temp\build4e04089fd1ea57703690da089d6e022c.tmp/Blink_LEDs.ino.bin -R

According to bossac.exe -h, there is no argument to to the -w switch but they have 'true' after it. I removed the true and ran it on the command line and it worked. Since that is embedded code in the IDE I will do what you just suggested until they get that fixed.

Thank you!

Hi Cody,

Happy to help. You can mark this thread as [CLOSED] now, see THIS thread I just created.



I just updated to 1.6.9 and the problem is gone! Thank You Graham!

I just got it for Arduino 1.6.8 after it updated the DUE package. I'm doing Due development. Not nice, since it was fixed in 1.6.9, installing updates to 1.6.8 should get be broken.

Solved my problem too thanks a lot...Downloaded Arduino1.6.9.

The error in composing the command line for bossac.exe is actually not an integral part of the IDE and is easily fixable in a configuration file. Here's the link to the solution:

This practically just removes the trailing "true" from the "-w" parameter and allows you to easily upload compiled sketches from within the IDE again. This problem still exists in the V1.6.9 of the SAM tools package which is currently the latest (as of this post).