Brand New Arduino Nano Connecting But Not Showing Port

I just bought a genuine Arduino Nano. I bought it for its compact design as I am currently using the MEGA 2560. I have had no issues connecting my MEGA to my PC and writing sketches to do. The new NANO seems to connect but does not show any ports. I downloaded the CH340 drive and it says "The drive was successfully Pre-installed in advance!" I hooked the same NANO up to a different computer which also did not show any ports. However, after downloading the CH340 drive, it worked fine and I was able to upload the BlinkLED. I have searched everywhere and even reached out to Arduino for technical support. This is my last option. Advice?

I can't help but if installing the CH340 driver solved the problem on the second computer, it's not a genuine Nano. A genuine Nano uses a FT232 chip.

Can you decipher the print on the chip omdat the bottom of the board?

Genuine. RT232RL chip.

Maybe you should try to install the driver for RT232 and not for CH340?
Virtual COM Port Drivers
See what your device manager says when plugging in the board.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.