Brand new RP2040 connect not showing on COM port - windows 10

I have had a new Arduino nano RP2040 connect arrive in the mail and after plugging it into my laptop it does not become recognised by my laptop (no sound when plugging it in), I can't see it anywhere in device manager and it doesn't show up on the Tools>port options in the IDE.

The initial blink programme runs and when I plug the board in I can see it flash between red, green and blue:

I have tried removing the board and placing a short between REC and GROUND before plugging it in again. Now, there is no flash and there is only asingle green LED which is on which I assume is the power-on LED of the board, but I still do not get any response from my PC or any change in the IDE:


I've seen some threads online explaining that you need to install drivers for older versions of windows, but I'm using the most up to date windows 10 and Arduino IDE, is there something really simple here that I am missing?

Try uploading a sketch. Even though the board is not recognized as a serial port, once you upload the first sketch it should then show up. The Arduino core library code that is loaded along with your sketch provides the USB CDC code that creates the serial port. So after you do the hardware reset by shorting the REC pin that USB CDC code is not running and you only get the flash drive interface.

Hi Pert,

thanks for the response. I see, I didn't know you could upload to the Arduino nano RP2040 connect even without a Port selected. I had the same problem yesterday with a Nucleo-32 board and had to download some other software to get that to appear so I wasn't sure if it would be the same case here.

I'm at work now but I will try to do what you have recommended once I get home

Hi Pert,

I've tried to upload a blank sketch to the board but this is the error I get:

I get the same error whether or not I try to upload the sketch with the short between REC and GND or left as an open circuit. The wire is also ok as this is the same cable I use to upload sketches to a normal Arduino Nano.

Thankfully, the RP2040 does appear in the bottom right-hand corner of the IDE so that's progress at least. Is there something else that I am forgetting to do?

You could try the alternative recovery method of copying the provided .uf2 file directly to the mass storage drive via your operating system's file manager, as documented here:

Hi Pert,

Thanks for the response again, unfortunately, the board is not appearing on my system as a storage device either, this is my 'This PC' folder with the board plugged in and the jumper between REC and GND:

I'll also check online to see if it doesn't pop up for other people. If my understanding is correct, should it appear next to windows in the file explorer as a separate drive?

Also, there is never a sound when I plug it into my PC, usually I get a sound whenever I plug in a USB drive/mouse/keyboard etc but the RP2040 connect never makes a sound when it is plugged in, does that mean that there may be something wrong with the board?

Make sure the USB cable is completely plugged into both the Arduino board and the PC.

You may have a damaged/defective or charge-only USB cable. Try a different cable.

Either of the above can result in the power connections being made (and thus LED lights on the board), but no data connections (and thus no port for the board).

It all works fine now! Turns out it was the cable, after getting a new USB cable everything worked first time

Thank you for all your help!

1 Like

You're welcome. I'm glad to hear it's working now. Enjoy!
Per