Braucht noch jemand Leerplatinen für einen ISP-Programmer?

Hallo,

da ich solche Steckbrettaufbauten nicht als Dauerlösung haben möchte, andererseits aus einer Fehlbestellung noch einen Stapel Nanos mit 168er µC hatte, habe ich eine kleine Platine für den Nano als ISP fertigen lassen. Natürlich geht auch der normale Nano damit...

Da der Chinamann aber nur ab 5 Stück fertigt und 10 Stück nur ein paar Cent mehr kosteten (kosten hauptsächlich Porto) sind also ein paar übrig.

|500x348 Mein Steckbrett

|500x264 Eine Falle lauerte allerdings noch. Wenn der Nano fest verlötet ist, kann man ihn selber nicht mehr flashen, da der Elko den Reset behindert. Notlösung: Leitung trennen und einen dünnen Draht nach hinten legen. Den kann man dann notfalls trennen und nach dem flashen mit einem Lötpunkt wieder schließen. (Eine eventuelle Neuauflage hat dafür einen Jumper)

|500x302 Auf der Unterseite hatte ich auch Platz für einen Elko vorgesehen, der obere (unter dem Nano) könnte ja zu hoch sein. (ist er aber nicht) Ich habe einen Lötjumper vorgesehen, um den Ziel-µC notfalls mit nur 3.3V zu versorgen. Das funktioniert aber nur bei µC, die an den Eingängen trotzdem 5V-tolerant sind (sind einige) Normalerweise lötet man an 5V.

|500x259 Fertig.... Die LEDs habe ich noch nicht bestückt, ich hatte nur noch zigtausend blaue. Eventuell die "Error-LED" hat Sinn, die leuchtet z.B. bei falsch konfigurierter Baudrate im Programmtool.

|500x294 Bei Interesse -> Mail ;) 1 Euro plus Porto.

Da ich noch mehrere 4000er Rollen blaue Leds habe (aber 0603!), lege ich kostenlos ein paar Zentimeter vom Gurt dabei (wenn gewünscht) Old-papa

So, die sind inzwischen alle weg.
2 fertig aufgebaute Programmer habe ich noch hier.

Falls ein paar Interessenten zusammenkommen, bestell ich nochmal welche, dann mit ein paar kleinen Änderungen.

Old-Papa

Ich würde eine nehmen.

Gruß Tommy

Tommy56: Ich würde eine nehmen.

Gruß Tommy

Na schaun wir mal...

Geändert gegenüber der ersten Auflage ist vor allem der "ELKO"-Jumper hinzugefügt, die LEDs (grün, rot und gelb, 0805) habe ich etwas auseinander gerückt. Den Elko kann man auf der Bestückungsseite löten oder unten oder sogar auf beide Positionen, falls einer nicht reicht. Unten stört er etwas, oben muss man den Arduino vielleicht etwas höher verlöten.

Bisher habe ich mit den Dingern viele µCs geflasht, mein Sohn und ein Bastelkumpel wohl ebenfalls (ich hatte ein paar fertig aufgebaute verschenkt). Allerdings habe ich mir meinen schonmal zerschossen, weil ich den Elkojumper nicht gesteckt hatte. Beim Nano mit dem 168P gibt es mit meiner IDE noch ein Problem, die kennt beim Nano nur den 168 ohne "P" (andere Signatur) Ich habe als "Würgarround" in der AVRDUDE.CONF für beide die Signatur vom 168 eingetragen. Ulkig, dass in der .conf zwar beide drin sind, die IDE damit aber nicht arbeitet....

Old-Papa

Ich nutze welche mit 328. Bestückung und Schaltung lieferst Du mit?

Gruß Tommy

Tommy56: Ich nutze welche mit 328. Bestückung und Schaltung lieferst Du mit?

Gruß Tommy

Nun, bisher hatte ich keine Schaltung gepinselt, da die wenigen Bauteile intuitiv erfasst werden können. Eigentlich steht in der INO die Beschaltung drin ;) In den Weiten des Netzes fand ich mal eine.

Bestückung steht ja drauf... ;)

Old-Papa

Ok, das genügt

Gruß Tommy

Allerdings habe ich mir meinen schonmal zerschossen, weil ich den Elkojumper nicht gesteckt hatte. Beim Nano mit dem 168P gibt es mit meiner IDE noch ein Problem, die kennt beim Nano nur den 168 ohne "P" (andere Signatur) Ich habe als "Würgarround" in der AVRDUDE.CONF für beide die Signatur vom 168 eingetragen. Ulkig, dass in der .conf zwar beide drin sind, die IDE damit aber nicht arbeitet....

Da ist nix komisches dran. Die IDE findet ihre Information in der betreffenden boards.txt.

Da findet sich "nano.menu.cpu.atmega168.build.mcu=atmega168" Andere 168 Nanos gab es nie original. Deiner muss also ein Nachbau sein.

Du könntest eine eigene boards.local.txt neben die boards.txt legen mit folgenden Eintrag

nano.menu.cpu.atmega168.build.mcu=atmega168p

Dann klappts auch mit dem P

Oder auch gleich dort einen weiteren Menüeintrag anlegen. Ist dann etwas Mehrarbeit, wird aber eine saubere Nummer.

Den "Würgarround"solltest du zügig wieder zurück ändern.(denke ich mal)

combie:
Da ist nix komisches dran.
Die IDE findet ihre Information in der betreffenden boards.txt.

Da findet sich “nano.menu.cpu.atmega168.build.mcu=atmega168”
Andere 168 Nanos gab es nie original.
Deiner muss also ein Nachbau sein.

Aha… So tief bin ich nie in die IDE eingestiegen.
Und Ja, das ist ein Chinaböller, aber er funktioniert in vielen Anqendungen sehr gut, hat halt nur weniger Ressourcen.

combie:
Du könntest eine eigene boards.local.txt neben die boards.txt legen mit folgenden Eintrag

nano.menu.cpu.atmega168.build.mcu=atmega168p

Dann klappts auch mit dem P

Oder auch gleich dort einen weiteren Menüeintrag anlegen.
Ist dann etwas Mehrarbeit, wird aber eine saubere Nummer.

Den "Würgarround"solltest du zügig wieder zurück ändern.(denke ich mal)

Ok, mach ich sicher mal, danke für den Tipp. Derzeit habe ich die 168P nur noch in den Programmern verbaut.

Old-Papa


Die blauen Jumper für die ELKOs habe ich nachträglich mit dünnem Teflondraht und Heißkleber angespaxt. :wink:
In der Neuauflage dann original.

combie: Du könntest eine eigene boards.local.txt neben die boards.txt legen mit folgenden Eintrag

nano.menu.cpu.atmega168.build.mcu=atmega168p

Dann klappts auch mit dem P

Oder auch gleich dort einen weiteren Menüeintrag anlegen. Ist dann etwas Mehrarbeit, wird aber eine saubere Nummer.

Fragen:

Mit welchem Editor bastel ich das? Mein Brot&Butter-Editor aus dem Totalcommander (Klassiker mit F4) zeigt alles ohne Zeilenumbrüche, das nervt....

Gibt es irgendwo eine Deutsche Erklärung zum Menueeintrag?

Old-Papa

Als Editor empfehle ich Notepad++.

Gruß Tommy

Gibt es irgendwo eine Deutsche Erklärung zum Menueeintrag?

Hmm... Eine in english gibt es

Als Editor empfehle ich Notepad++.

Mein Liebling ist PSPad

Ja, der ist auch gut. Im Endeffekt ist es wohl, wie mit vielen Dingen, eine Frage der Gewohnheit. Ich habe mir mittlerweile Syntax Highlighting für Arduino und einige nützliche Tastaturmakros eingebaut.

Gruß Tommy

So, einen 10er Pack habe ich gerade geordert, doch die Preise zogen wohl etwas an. Mit Porto&Pack waren dafür heute knapp 14 Euro fällig.

Ich schätze in etwa 20 Tagen sind die Dinger hier.

Old-Papa

Hallo,

auch wenn mein Username und -account durch das Forumsupdate vergurkt wurde, die Platinen sind inzwischen angekommen.
Bei Bedarf old-papa(ÄT)web(punkt)de

Gruß
Old-Papa