Bricked my nano wii (Atmega32u4)

I have a multi-rotor flight controller called Nano Wii,

It has Atmega 32U4 mpu and gyro sensor.

And this programmer,

I loaded Multiwii ver 2.1 on it a few times (changing some parameters each time), and used Multiwii config program to verify everything was working with USB cable.

Then I found out about flight mode called horizon mode in multiwii ver2.2, this version is larger then ver2.1 (I am guessing it over wrote my bootloader). After loading it, that was the last time I could talk to the board (I think it over wrote the boot loader, I am super new to all this firmware, but not electronics). I tried reloading the boot loader though USBasp (and another USBasp version) and using ardriuno. I chose my programmer in arduino and my nano wii (leonardo) and there is no com number to set with this programmer.

Double checked my wiring, tried several times. I just get the can’t set sclk error (see picture). I am pretty sure its not the programmer, I also bought one that specifically can control the sclk freq (my second programmer) and it flashes my KK2 flight control boards, electronic speed controls and my turnigy 9x transmitter, so I know my programmer is fine.

I have tried with Win7 and WinXP,

I have wired up Miso, Mosi, SCLK, RST, +5V and GND, triple checked my connections.
Hooking a scope up revealed Atmega 32u4 is not talking back to programmer (Miso), The other three signals were toggling.

Any help would be appreciated!

Download the progisp v1.72 from here:
It's support the USBASP and many, maybe all, atmel controller.

I hope I help for You!

Any luck with this? I'm in the same boat. I've been able to figure out all the pins but the MISO. It looks like D12 is missing from the NanoWii V01 board.

I have not de-bricked it, many attempts though. I will get it out of the box and look for the MISO connection, maybe if you fix yours you can let me know the steps.

Would you happen to have a picture of how you connected your USBasp to your NanoWii? I want to sanity check what you did with what I did.

Thus far, I've connected the USBasp to the board using a combination of the pin layout from HK and this site:

The only one that's unclear is the MISO connection since it's supposed to be on pin D12. Unfortunately, the NanoWii is missing that specific pin. I tried every open pin, but was unsuccessful.

Here is my connections, let me know if you see something wrong, thanks and good luck. I am using the HK USBasp programmer, I have flashed ~50 ESC’s. ~15 9x Tx’s and ~12 KK2.x flight controllers, so I know my programmer is working. I even tried a USBasp that can set the SCK speed (the HK version can not). Depending on your PC setup, slide to the right to see the whole picture.

Hoooly crap. You fixed it! My pins were all wrong. Here’s what mine looks like now.

Here’s what I did:

  1. Set up my USBasp to this

  1. In Arduino IDE, I had the MultiWii sketch open and then selected File > Upload Using Programmer

It took a few minutes but then ended up with a success message at the end. BOOYA!

Cool, glad I could help.

I am using Ardrino and using the tools tab (not file tab like you), then I click burn boot loader. Maybe this is where I am going wrong.

So you load the MultiWii 2.1 in Arduino, then just do file tab, then "upload using programer"?

Did it load Multiwii and bootloader or just the boot loader?


I had no luck with the Burn to Bootloader option. Luckily, loading MultiWii 2.2 through the Upload Using Programmer worked.

It's possible that it loaded the bootloader with it, but I can't be sure. I thought it just loaded the Sketch, but I'm now having an issue loading sketches using USB. The last upload was done through the USBasp. I remember skimming a thread that mentioned that something may have changed after flashing with a programmer that makes it programmer-only going forward. Then again it could just be my computer.

It sounds like the boot loader did not load (that's what makes the USB port work).

As I understand, MW 2.2 is to large for the nanowii, that is what bricked mine (I think over writing the boot loader)

Are you using a Lite version of MW 2.2?

Hmmm. I’ll try to see if i can’t find that thread.

I had no problems loading MW 2.2 on it. I used the config tool and the build came out to 20k. The system should have 8k leftover for bootloader, etc.

I am new to MW and ardruino. What config tool you talking about?

I was in ardruino and in the config.H tab, commenting/un-commenting to config for a tri-copter, cppm, etc. I was succesful with MW 2.1, but 2.2 = brick :grin:

This guy:

It asks you a number of questions about your board and any options you'd like and then creates a config.h for you. Supports up to MW 2.2

I wonder if this would work with my NanoWii PocketQuad. HK shipped it with a bad bootloader and I haven't had the time to go through all the hoops to return it. I also have a standard NanoWii IMU that seems to work fine with MW 2.3 so I know my programming set up should be fine.
I have a generic USBasp but I gave up on it after I couldn't find any updated firmware to go with it. Can anybody recommend any other tools like ProgISP that work with Linux or OSX?

I never got the nano wii working, but good news, is selling the acro mullet (clone of the Acro Naze) for $21.50 + $5 shipping, the blows away the 8 bit flight controller ten fold. The Mullet FC will be up on the sight in a day or two.


Check out AVRdude for OS X. The link below is a decent guide to a number of other alternatives. OS X comes with drivers for the USBasp out of the box. If it isn't supported, it's prob a defective unit or something you wouldn't want to deal with anyway.