BUG ESP 8266

Bonjour a tous,

J'ai le problème suivant, j'ai un esp8266 connecté à un nano en serial software.
tous fonctionne très bien ! mais après un certain temps aléatoire selon moi l' ESP ne répond plus !
Attention la connexion entre L'ESP et le nano est toujours ok , la diode bleu de l'ESP ne clignote plus a l'arriver de data via le wifi !!! le module est toujours visible du réseau, la connexion de mon gsm vers l' ESP est toujours OK mais pas de data ! j'ai vérifier avec un autre GSM si des fois !! s'est vraiment l'ESP !!

Donc dans mon programme cote nano dans une boucle FOR apres 200 cycles je repasse par l'INIT de l'ESP et la il refonctionne !!! c'est une solution qui ne m'arrange pas vraiment !!!

J'ai chercher a changer le firmware après commande AT+CIUPDATE le cycle commence et reste en attente au point 3 !!! pas d'update :(.

AT version:0.21.0.0
SDK version:0.9.5

Mais cela vous dit quelque chose comme problème ?

Merci de votre aide.

Voila le sdk et version :

AT version:0.21.0.0
SDK version:0.9.5

postez votre code et la façon dont tout est alimenté... ça peut-être dû à de nombreux facteurs...

Le_Joebar:

J’ai le problème suivant, j’ai un esp8266 connecté à un nano en serial software.

J’ai chercher a changer le firmware après commande AT+CIUPDATE le cycle commence et reste en attente au point 3 !!! pas d’update :(.

Bonsoir
Puisque tu es là venu sur le forum arduino , pourquoi ne pas tester l’esp8266 sous l’IDE arduino ? :grin:
perso les variantes SDK/ commandes AT , j’ai depuis déjà pas mal de temps … laissé "tomber

Mon motage a besois de la puissance de l'arduino pour la gestion et du esp pour le wifi.
J'avais commence avec se materiel des la comercialisation du ESP 8266.
Mon montage est deja en place et fonctionne bien sauf ce BUG ESP8266 qui perd la connexion sans raison !!
S'est pour sa que je vais essayer de le flashé en changeant le sketh de mon arduino, et remettre le skech apres flash et voir si c'est plus stable.

:wink:

L'ESP est Bcp plus puissant que votre arduino d'un point de vue calcul...

Dans l'absolu gérer une déconnection / reconnection au réseau est nécessaire pour le cas où votre wifi tombe... Donc reset de temps en temps pas une mauvaise chose

OK ! Si je lance une commande AT+ RST dois - je refaire une INIT apres ou vas t'il reprende s'est parametre precedent IP MODE PASSWORD etc ?

Bête question je n'ai qu'a essayer lollll

LOL - si vous avez sauvé les infos (de mémoire il y a 2 commandes pour régler les paramètres, une qui mémorise et l'autre non) alors pas besoin de les remettre

Bon bien j'ai avance sur la question !!!!
J'avais 2 ESP 8266 01 le premier qui équipais mon système avais la version AT version:0.21.0.0
SDK version:0.9.5 et impossible je ne sais pour quelle raison le flashe via wifi.
Le second que j'avais sur ma board d'essais avais une mise a jour reussie, je n'ai pas note la version mais s'est sans importance!
Resultat avec la nouvelle version le systeme en cas de perte du reseau redemare seul reprend la config et ne plante pas.

Resultat 5 Jours de fonctionnement sans bug.

Par contre me reste un probleme !!!

Comment mettre a jour l'ancien qui en wifi ne veux pas !!!!
Pour flashe le firmware il me faudrait un module FTDI mais a quoi bon un NANO ne pourrait il pas faire l’affaire ?