[BUG] Java(TM) Platform SE Binary has stopped working (IDE 1.5.4-Win8.1)[SOLVED]

Hi guys,
I have a problem or a bug. I'm using arduino IDE 1.5.4 on windows 8.1 machine. I'm constantly getting this error: Java(TM) Platform SE Binary has stopped working. This bug appears almost everytime when I try to open Serial Monitor and when I try to upload the sketch to the arduino board. After this bug window appear the arduino IDE crash and closes itself. Then I need to reopen arduino but usualy this doesnt help, so I need to restart my computer.

Then I downloaded latest version of java for windows (http://www.java.com/en/download/index.jsp) with no success. This error has appeared imediately when I upgraded computer via Windows 8 Store. On Win8 it all worked flawlessly. I have already tryed to remove arduino IDE and reinstall with fresh copy from arduino website. I even intall it with compatibility mode set to windows 8, but no success.

I can verify program without issues, I can change board, COM port etc.

Any ideas how can I solve this problem. I can't do nothing on this machine and this error is getting me crazy :drooling_face:

Best regards,

What Arduino board do you have?

Hi Nick,
I do have an official arduino DUE board and few Leo's. But the error only occurs on DUE board.
Best regards,

Some people have suggested running the IDE in compatibility mode for Windows XP. See if that helps.

Well, I must say that this "bug" was totaly wrong interpreted. Looks like it was an sketch problem. I had an array of data which can hold 0-31 values (P[0-31]). Somewhat I have writed a code that was trying to access P[32], which actualy doesn't exist. So the program hanged up obviously, and next time when I tryed to open serial monitor or reprogram DUE, the Arduino IDE has crashed. If I wanted to work with serial monitor again, I had to disconect DUE from power (USB cord), close the Arduino IDE, open Arduino IDE, connect the DUE board and pressed reset button on board. So this bug was actualy partly my mistake since the compiler didn't recognized my mistake.

It was a big coincidence that I changed code right before updating Windows. Well this is finaly solved, thank god.

Thank you Nick for help.

Have fun, Jakob