Bug with Buzzer

This program doesn’t work …
Can you help me ?
The code :

#include <IRremote.h>
#include <IRremoteInt.h>

const char Rec = 2;

IRrecv RIR (Rec);

decode_results Recu;

void setup()
{
  Serial.begin(9600);
  RIR.enableIRIn();
  RIR.blink13(true);
}

void loop()
{
  if (RIR.decode(&Recu))
  {
    if (Recu.value == 0xE318261B)
    {
      tone(7, 7000, 50);
    }
    if (Recu.value == 0xC101E57B)
    {
      tone(7, 7000, 50);
    }
    if (Recu.value == 0x9716BE3F)
    {
      tone(7, 7000, 50);
    }
    if (Recu.value == 0x3D9AE3F7)
    {
      tone(7, 7000, 50);
    }
    if (Recu.value == 0x6182021B)
    {
      tone(7, 7000, 50);
    }
    if (Recu.value == 0x8C22657B)
    {
      tone(7, 7000, 50);
    }
    if (Recu.value == 0x488F3CBB)
    {
      tone(7, 7000, 50);
    }
    if (Recu.value == 0x449E79F)
    {
      tone(7, 7000, 50);
    }
    if (Recu.value == 0x32C6FDF7)
    {
      tone(7, 7000, 50);
    }
    if (Recu.value == 0x1BC0157B)
    {
      tone(7, 7000, 50);
    }
    if (Recu.value == 0x3EC3FC1B)
    {
      tone(7, 7000, 50);
    }
    RIR.resume();
  }
  delay(1);
}[/b]

And the bug code :

Tone.cpp.o (symbol from plugin): In function `timer0_pin_port':

(.text+0x0): multiple definition of `__vector_13'

libraries\IRremote\IRremote.cpp.o (symbol from plugin):(.text+0x0): first defined here

c:/program files (x86)/arduino/hardware/tools/avr/bin/../lib/gcc/avr/4.9.2/../../../../avr/bin/ld.exe: Disabling relaxation: it will not work with multiple definitions

collect2.exe: error: ld returned 1 exit status

exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.

Please don’t use the “report to moderator” to bump your post.

This program doesn’t work .

No, this program doesn’t compile.

It looks like the tone() function and the IRremote library aren’t on speaking terms.

so i can't use passive buzzer and IR same time ? But it work with a active buzzer

See this for a solution: http://forum.arduino.cc/index.php?topic=454873.msg3127065#msg3127065