Burning Arduino bootloader to Atmega2560

Hi, i am not able to burn Bootloader in my custom board which has Atmega2560...actually,in my custom board,i am using Atmega16u2 chip as usb to serial programmer..
I followed below procedure

  1. I connected my board to pc(windows 8.1,64 bit os) with the help of usb cable.
  2. Then i checked device manager in pc..my board was displaying in other devices like Atmega16u2(DFU)
  3. I installed atmel studio 6.0 and FLIP3.4.7 also( i follwed below link "How to Flash Arduino Bootloader without a Programmer – Welldone Blog" )
  4. Next,on my custom board,icsp of usb controller-->i linked 5-6 pins(reset and ground pins)then i gave power to my board means conneted usb cable to pc..
  5. In Device Manager board displaying under other devices like Atmega16u2(DFU) with yellow color exclamatory symbol.
  6. Then i right clicked that Atmega16u2 DFU and updated driver software(choosen path from my pc...
    path: "OS(C)/programfiles(X86)/Atmel/Flip3.4.7/usb"
  7. Finally Installed...then it showing Atmega16u2 under libusb devices in Device Manager..
  8. After this,i uploaded avrisp mkII hex file from flip software... i removed usb cable connection ..again i connected that usb cable to my pc...
    main problems i found:
  1. avrisp mkII device displaying under libusb devices folder...instead of jungo connectivity..
    2)in atmel studio 6.0,i found avrisp mkII as tool,then i selected device i.e Atmega2560 next i clicked apply button...but im getting error popup like
    "unable to connect to tool AVRISP mkII(000200312345)"
    details: Timestamp: 2017-07-26 16:15:56.862
    Severity: ERROR
    ComponentId: 20000
    StatusCode: 0
    ModuleName: TCF (TCF command: Tool:connect failed.)

can u please tell me,which version of atmel studio will support windows 8.1,64bit and why jungo connectivity is not getting avrisp mkII instead of libusb devices
how can i approach burning bootloader in atmega2560 ...plz tell me exact procedure

sailaja:
why jungo connectivity is not getting avrisp mkII instead of libusb devices

Uninstall the libusb driver, install the Jungo driver. Note that if you want to use your AVRISP mkII with the Arduino IDE then you need the libusb driver. If you want to use your programmer in both Atmel Studio and the Arduino IDE there is a way to have both installed, if you search on the avrfreaks forum you will find instructions for doing that.

sailaja:
how can i approach burning bootloader in atmega2560 …plz tell me exact procedure

If you insist on this crazy approach then you will just need to follow that tutorial. It seems excessively over complicated to me. If you’re to the point of making custom boards then you should just buy a $3 USBasp off eBay. It’s also possible to use an Arduino board or any AVR microcontroller as an “Arduino as ISP” programmer. See:

If you do that you might want to use the Arduino IDE as it will be very easy.

thank you....
i wil try ,what you suggested....if any problem get,let u know...

hi,
i tried with usbasp...getting errors with that
i follwed below procedure

  1. I connected usbasp to my pc,updated driver software "USBasp-win-driver-x86-x64-ia64-v1.2.5"
  2. then i checked in device manager...usbasp device is showed under libusb devices..
  3. then i opened my arduino ide...i connected tool settings as board and processor-->Arduino mega
    2560,programmer-->usbasp
  4. then i clicked burn bootloader...

Here i got some errors like

avrdude: Warning: cannot query manufacturer for device: No such file or directory
avrdude: Warning: cannot query product for device: No such file or directory
avrdude: error: could not find USB device with vid=0x16c0 pid=0x5dc vendor='www.fischl.de'
product='USBasp' Error while burning bootloader.

after this i searched in arduino forum about this problem

then i found somewhere solution for this problem...i.e

I was using libusb-win32 v1.2.4.0. Using libusb-win32 turns out to be the problem. Once I updated
the driver to libusbK v3.0.7.0 the problem was solved, thanks DrAzzy! Here's how I did it:

Plug in USBasp
Download Zadig from http://zadig.akeo.ie
Start zadig
Options > List all devices
Select USBasp from the drop down menu
Select libusbK(v3.0.7.0) driver
Click Install

5.i follwed above procedure...then im getting this error
Sketch uses 1,896 bytes (0%) of program storage space. Maximum is 253,952 bytes.
Global variables use 190 bytes (2%) of dynamic memory, leaving 8,002 bytes for local variables.
Maximum is 8,192 bytes.
avrdude: warning: cannot set sck period. please check for usbasp firmware update.
avrdude: error: program enable: target doesn't answer. 1
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

the selected serial port
does not exist or your board is not connected

can u plz tell me the correct procedure to burn bootloader in atmega2560 using usbasp??...im not getting perfect solution for this problem...plz help me....

How does your other post:

affect this thread? Does the different issue you're encountering there indicate that you've progressed beyond this one?

It's problematic to have multiple threads because people trying to help you on one thread may be missing important information that's only contained in the other thread.

k thankyou..i will follow only one thread