burning bootloader with external programmer

Hello, I've got serious trouble with burning bootloader for arduino uno to atmega328-PU. Arduino console write out:

avrdude: error: programm enable: target doesn't answer. 1 avrdude: initialization failed, rc=-1 Double check connections and try again, or use -F to override this check.

But I've got GUI program to write .hex to avr which internally use avrdude and it works fine. I recognize correctly my atmega. My arduino ide version is 1.6.3

All I did to configure was Tools -> Programmer -> Usbasp, then: Tools -> burn bootloader

Maybe I need to configure something else to make it work?

I made some investigation:

when I run this command directly from cmd:

avrdude -p atmega328p -c usbasp -P usb -B 8

it write out:

avrdude: set SCK frequency to 93750 Hz
avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.05s

avrdude: Device signature = 0x1e950f

avrdude: safemode: Fuses OK

avrdude done.  Thank you.

so from avrdude all is working. So it's a problem with Arduino settings i guess

I've just found:

I've got 2 avrdudes:

1 is on "C:\WinAVR-20100110\bin" 2 is on "C:\Program Files (x86)\Arduino\hardware...\avrdude

so my actual question is how to force arduino to use avrdude from first localization?

Is avrdude provided with arduino is in any kind special to force me to use this version or is it irrelevant to use any of them?

Next investigation:

after writing this command:

C:\"Program Files (x86)"\Arduino\hardware\tools\avr/bin/avrdude.exe -CC:"\Program Files (x86)\Arduino\har dware\tools\avr/etc/avrdude.conf" -p atmega328p -c usbasp -P usb -B 8

my arduino avrdude says:

avrdude.exe: set SCK frequency to 93750 Hz
avrdude.exe: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.06s

avrdude.exe: Device signature = 0x1e950f

avrdude.exe: safemode: Fuses OK (H:07, E:D9, L:62)

avrdude.exe done.  Thank you.

So my arduino avrdude workings too. Is it possible that i have to configure fuse bits before start uploading bootloader ?

Here is command my arduino is trying to burn bootloader:

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -cusbasp -Pusb -e -Ulock:w:0x3F:m -Uefuse:w:0x05:m -Uhfuse:w:0xDE:m -Ulfuse:w:0xFF:m

Guys, could somebody help me?

here is detailed message:

avrdude: Version 6.0.1, compiled on Mar 30 2015 at 14:56:06
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : usb
         Using Programmer              : usbasp
         AVR Part                      : ATmega328P
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PC2
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    20     4    0 no       1024    4      0  3600  3600 0xff 0xff
           flash         65     6   128    0 yes     32768  128    256  4500  4500 0xff 0xff
           lfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           hfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           efuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           lock           0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

         Programmer Type : usbasp
         Description     : USBasp, http://www.fischl.de/usbasp/

avrdude: auto set sck period (because given equals null)
avrdude: error: programm enable: target doesn't answer. 1 
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

SOLUTION:

After two days of fighting with Arduino I finally found why my atmega wasn't visible for avrdude. It's all becouse of default settings in platform.txt. There is section named tools.avrdude.bootloader.pattern which have to have option -B 8. So now my section looks like:

"{cmd.path}" "-C{config.path}" {bootloader.verbose} -p{build.mcu} -c{protocol} {program.extra_params} "-Uflash:w:{runtime.platform.path}/bootloaders/{bootloader.file}:i" -Ulock:w:{bootloader.lock_bits}:m -B 8

and it works!. I managed to load arduino bootloader to atmega328p!