By using Software serial the monitor prints "Garbage"

Hi,

I’ve connected a GPS to the Arduino 101 board by using “Softwareserial” and it prints “Garbage”.
But when I used the hardware pins for rx\tx (with Serial1) it’s working fine.
I need to find a way to make it work with Softwareserial cause I need to connect more modules to the board.
I tried also to connect ESP, and there’s the same problem.
So it seems to be a problem with the board or the software.

I did this before with arduino uno and I didn’t have any problems.

I’ll appreciate your help,
Thanks in advance.

code example: (I’ve already tried diffrent baudrates).

#include <SoftwareSerial.h>
#include <stdlib.h>
#define rxPin 9
#define txPin 11

SoftwareSerial gps = SoftwareSerial(rxPin, txPin); // RX, TX

void setup() {
pinMode(rxPin, INPUT);
pinMode(txPin, OUTPUT);
Serial.begin(4800);
delay(500);
while(!Serial);
Serial.println(“START”);
gps.begin(4800);

}

void loop() {
while (gps.available())Serial.write(gps.read());
while (Serial.available())gps.write(Serial.read());
}

Problem SOLVED.. I tried to install an old version of the board (1.0.4) and now it works.
I don't know why it does not work with the latest version.

Hi,
would you mind opening an issue on GitHub - arduino/ArduinoCore-arc32 with a full report (so it can be solved in mainline version) ? Thanks!