Byte commands to Lazybone BT AC dimmer via HC-05 stop functioning

I have Lazybone bluetooth AC lamp dimmer which I would like to control by Arduino. I started to develop Arduino code, but I came across about problem that I could't solve by myself. I have tried to keep code as simple as possible.
I have arduino connected to HC-05 bluetooth module like below:

Arduino Uno 5V -> HC-05 5V
Arduino Uno GND -> HC-05 GND
Arduino Uno RX -> HC-05 TX
Arduino Uno TX -> HC-05 RX

HC-05 bluetooth module is connected to Lazybone dimmer. Here is more information about Lazybone dimmer:
http://www.tinyosshop.com/index.php?route=product/product&path=141_164&product_id=626

Here is my code:

byte lampOff[] = {0x6F, 0x00, 0x0D }; //Turn off  Lamp
byte lampOn[] = {0x65, 0x00, 0x0D }; //Turn on Lamp
byte lampHigh[] = {0x67, 0x00, 0x0D }; //Set lamp to Brightest value
byte lampLow[] = {0x67, 0xC8, 0x0D }; //Set lamp value to 200
void setup() {
  Serial.begin(9600);
  delay(5000);
}

void loop() {
  Serial.write(lampOff, 3); //Turn off  Lamp -- This section works as it should
  delay(3000);
  Serial.write(lampOn, 3); //Turn on Lamp -- This section works as it should
  delay(3000);
  Serial.write(lampHigh, 3); //Set lamp value to Brightest -- Lazybone module won't react to this command at all. Even it looks valid  on my android phone.
  delay(3000);
  Serial.write(lampLow, 3); //Set lamp value to 200 -- Lazybone module won't react to this command at all. Even it looks valid  on my android phone.
  delay(3000);
}

HC-05 module is connected to breadboard so I can change Lazybone connected HC-05 module to another HC-05 bluetooth module which is connected to my android phone. Then I can get byte stream of my code. Every command look valid on byte stream but still commands that should set Lamp dimming value won't work on Lazybone. Here is picture of bytestream:

First two commands work's properly on every loop on Lazybone module. Following commands that should set lamp value won't get any reaction on Lazybone.

I would appreciate a lot if someone could give me a hint why last two commands wont work as others.

I have also tried to send same dimming commands from my phone to Lazybone and then every command works fine.