Cactus Micro Rev2 ESP Serial Communication

Hello. I’m trying to communicate with ESP via Mega32U4. I successfully upload .bin file with NodeMCU flasher but it doesn’t give any respond. I can’t even communicate simple serial. ESP side sketch file:

#include <ESP8266WiFi.h>

const char* ssid = “ADIisim”;
const char* password = “biseylerbiseyler123”;

void setup()
{
Serial1.begin(115200);
}

void loop()
{
Serial1.println(“Hello”);
delay(1000);
}

Settings (I’m not sure this settings, maybe wrong is here):

I extracting .bin file with Arduino IDE and send to flasher with this settings:
Baudrate: 115200
Flash size: 512kB
Flash speed: 40Mhz
SPI Mode: DIO

Mega32U4 side sketch file:

while(Serial1.available()) {
String character = Serial1.readString();
Serial.println(character);
}

Serial port didn’t give any value. And I don’t know ESP firmware version. I tried firmware update (espduino/esp8266/release at master · AprilBrother/espduino · GitHub) via esptool but it gave connection error. And I can’t erase flash it still gives an error. This time I tried via nodeMcu flasher:
3

It succeeds, but I still get no response. I could be wrong in two places:
First, I can't update espduino so it doesn't work.
Second, the settings I used while flashing the sketch to the ESP are not correct (First image or NodeMCU Flasher Advanced settings).

Use the esp8266Programmer.ino sketch in 32u4 as I write in an Answer to your Arduino SE question.

Problem had solved in the arduino.stackexchange: