Calling windows IDE with commandline argument

I have a problem starting the IDE (Windows) with a command line argument.

Starting with

arduino.exe filename.ino

is OK but I get the error "Kann keine Sketch-Dateien" angegeben" if i have a link:

arduino.exe --board arduino:avr:uno filename.ino

Whats wrong?

A previous version (I think 1.5.0) was fine.

Herbert

If you look at the documentation: https://github.com/arduino/Arduino/blob/master/build/shared/manpage.adoc it says:

if any of the following command line options is given, no graphical interface will be shown and instead a one-off verify (compile) or upload will be done.

It's not very clear if the --board option is one of them but if you try something like:

arduino_debug --board arduino:avr:uno --verify filename.ino

That works fine.

Thank you for the reply!

I created the topic because I want to start the IDE for different sketches. Each sketch is assigned to different Arduino boards (I have sketches for a “mega”, a “due” and also for “uno”). If I use the Windows shell integration (double click on the ino file), I have to configure the boards and serial manually. I want to have a link where I can start the IDE with my sketch and automatically select the board and serial (without compiling).

I thought, the command line arguments are intended therefore. Do you know a solution therefor?

I agree that is a nice feature and it is unfortunate if that functionality has been changed. I don't know if it was intentional or not. I would try this with previous versions from https://www.arduino.cc/en/Main/OldSoftwareReleases#previous until you find the last version that it still worked in and then report the issue to http://github.com/arduino/Arduino/issues with a note of the last version where this worked, that will help them to determine what they did to cause the change in behavior.

I found a solution for you. You need to do it in two commands:

arduino --board arduino:avr:uno
arduino filename.ino

now I use:

cd C:\Program Files\Arduino

start "x" /wait arduino.exe --board arduino:avr:mega arduino.exe ProxxonMF70.ino

This is fine for me