can not configure Arduino Nano IoT 33 for IoT Cloud

Hope some one can help on this issue:
I tried to add my new Arduino Nano IoT 33 to IoT Cloud.
it can find the board, and shows:
Arduino NANO 33 IoT found
An Arduino NANO 33 IoT has been detected on port COM8 and ready to be configured.
So I clicked the "configure" button, it went to the following procedure:
Make your device IoT–readyYour Arduino NANO 33 IoT will now be configured to communicate securely with the Arduino IoT.
The process can take up to 5 minutes, please do not disconnect the device.
It can pass step 1 and step 2, but in step 3, it shows:

We were not able to configure the Secure Element
Can't update Firmware: 'loaderPath' is empty or 'null'
Are you sure you have an Arduino board connected to your computer? Try disconnecting and connecting it again. Make sure plugin is running or restarting it. Do you see at least the power LED on your device lighting up?
I tried several times, and also updated the firmware through Arduino Desktop IDE, but still had the same issue.
Anyone can help? Many thanks.

Hello zlin999,

what is the version of your Arduino Create Agent and Operative System? You can find the Arduino Create Agent by clicking on the Arduino icon on the topbar.

Hi, Eclipse1985, thank you for the message.
the agent version is 1.1.251-318de37, and my PC operative system is WIN7.
thank you.

eclipse1985:
Hello zlin999,

what is the version of your Arduino Create Agent and Operative System? You can find the Arduino Create Agent by clicking on the Arduino icon on the topbar.

We are working hard to solve most of the bugs related to our Arduino Create Agent on Windows. In the meantime, have you tried to simply restart your PC, disconnect/reconnect the board, and retry the setup process?

I have a similar problem as the original poster except with a nano 33 IOT. I'm running Windows 10 and Chrome, at the latest patch levels. The Create Agent version is 1.1.251-318de37. The nano works fine. I've downloaded example sketches to it and run them successfully. It fails step 3 of the configuration with this error:

We were not able to configure the Secure Element
Cannot set property 'f4f4229a-1ea1-40c1-9cd5-544ecdc36f3a' of undefined

I managed to connect those Nano 33 IoT boards to LabVIEW program via TCP (WiFi), so that I can monitor multiple boards through LabVIEW panel.
but I am still waiting for the fix of this bug so that I can use IoT cloud.

I had the same problem with my Nano 33 IOT, where it failed on the Secure Element step while setting up the device, and it worked for me after the Arduino Create Agent installed the correct drivers. I'm using Windows 10.

Here's what I did:
From IOT Cloud page, went to Devices tab
Add Device
Set up an Arduino device
While the device configured, I saw Arduino Create Agent open and when I looked it prompted me to install Genuino/Uno drivers.
After the drivers were installed, the 3rd step completed and I was able to link the Arduino without any problems.

Hope this helps!

Hello, I had exactly the same problem with Thomas. Although the board works fine with the simplewebserverwifi example, when I try to configure my Arduino nano 33 IoT it fails the 3rd step and I get this message:

We were not able to configure the Secure Element
Cannot set property ‘…’ of undefined

Using
Windows 10 build 18363
Chrome 87.0.4280.66
Arduino IDE 1.8.15
WifiNiNa 1.8.0
Nina 1.4.1
Arduino Create Agent 1.1.252

We just deployed an update to our platform.

Can you also please try using Arduino Create Agent 1.2.0-rc1 at Releases · arduino/arduino-create-agent · GitHub ?