Can not get Ethernet Shield working at all

I have been playing around with the arduino for a long time and have recently ventured into the realm of the Ethernet shield. I have tried using the basic example web client and web server that is included in the Arduino 18 software and i can not get any response from the unit.

When i used the web client, the serial output just indicated: Connecting... Disconnected

When I ran the web server example, i was never able to connect to it.

I have tried using the webduino libraries and examples with the same results.

I have even gone as far as purchasing a second ethernet shield.

I am about to give up!

Any suggestions?

This is what i have: Windows 7 64bit Netgear WNR3500L router with DD-WRT firmware Arduino Duemilanove 2x Arduino Ethernet Shields

Official Wiznet 5100 shields ?. There is a cheaper type of shield using the ENC28J60 chip which doesn't work with the standard libraries.

Other than that it could be an IP address/ routing issue.

It's definitely the wiznet shield

Do you understand what you’re doing with IP addresses and subnets ?

I absolutely do. But here is my router info:

DHCP Range - Gateway Subnet

I setup the same gateway in the arduino and subnet and then pick an IP like and i still can not connect. I have no idea why.

Have you got anything else plugged in to the arduino?

Could you post the code you're using? There may be somethign you haven't spotted in it that fresh eyes might pick up on.

Have you confirmed the ethernet cable you're using is good?

You should be able to ping the Wiznet irrespective of the sketch, will it return a ping ?