Can not get Stack Trace Decoder to load

I tried putting the damn EspExceptionDecoder.java in the appdata folder, the program files folder, and documents folder. It doesn’t show up under tools. It was working before I upgraded to 1.8.8.

Any clues as to what might be wrong?

Directory of C:\Users\matt\My Documents\arduino\tools

019-03-02  15:02    <DIR>          .
019-03-02  15:02    <DIR>          ..
019-03-02  15:02    <DIR>          EspExceptionDecoder
019-02-05  18:40            19,979 EspExceptionDecoder.java
019-03-02  14:56    <DIR>          src
              1 File(s)         19,979 bytes
              4 Dir(s)  138,391,076,864 bytes free
 Directory of C:\Program Files (x86)\Arduino\tools

2019-02-05  18:40    <DIR>          .
2019-02-05  18:40    <DIR>          ..
2019-02-05  18:49    <DIR>          espExceptionDecoder
2018-12-06  06:24             5,437 howto.txt
2019-02-05  05:02    <DIR>          Mangler
2019-02-05  05:02    <DIR>          WiFi101
               1 File(s)          5,437 bytes
               5 Dir(s)  138,390,945,792 bytes free

Also reported at:

I see you've gone with the shotgun installation method, spewing all sorts of garbage across your hard drive, rather than following the clearly written instructions in the readme. The best thing is to delete all that and start with a fresh and correct installtion:

  • Delete C:\Program Files (x86)\Arduino\tools\espExceptionDecoder
  • Delete C:\Users\matt\My Documents\arduino\tools\EspExceptionDecoder
  • Delete C:\Users\matt\My Documents\arduino\tools\EspExceptionDecoder.java
  • Download the compiled latest release of the tool: https://github.com/me-no-dev/EspExceptionDecoder/releases/download/1.1.0/EspExceptionDecoder-1.1.0.zip
  • Unzip the downloaded file.
  • Copy the unzipped folder to C:\Users\matt\My Documents\arduino\tools
  • Restart the Arduino IDE if it's running.
  • File > Preferences
  • Verify that the "Sketchbook location" preference is set to "C:\Users\matt\My Documents\arduino". If not, you need to either change the preference to C:\Users\matt\My Documents\arduino or install EspExceptionDecoder to the tools subfolder of your actual sketchbook folder. If you have to do either, make sure to restart the Arduino IDE after doing so.

The folder structure of a correct installation looks like this:

{sketchbook folder}
|_tools
|_EspExceptionDecoder
|_tool
|_EspExceptionDecoder.jar

Thank you. Now it loads.

You're welcome. I'm glad to hear it's working now. Enjoy!
Per