Can not initiate HTTP connection

Greetings,
I have tried to use the sketch of Arduino Web Client found here: http://arduino.cc/en/Tutorial/GSMExamplesWebClient
and I updated the APN, login and password according to Vodafone Egypt, which is the SIM card im using, my updated code is:

/*
 GSM Web client

 This sketch connects to a website using a GSM shield.

 Circuit:
 * GSM shield attached

 created 8 Mar 2012
 by Tom Igoe
 */

// libraries
#include <GSM.h>

// PIN Number
#define PINNUMBER ""

// APN data
#define GPRS_APN       "internet.vodafone.net" // replace your GPRS APN
#define GPRS_LOGIN     "internet"    // replace with your GPRS login
#define GPRS_PASSWORD  "internet" // replace with your GPRS password

// initialize the library instance
GSMClient client;
GPRS gprs;
GSM gsmAccess; // include a 'true' parameter for debug enabled

// This example downloads the URL "http://arduino.cc/"

// URL, path & port (for example: arduino.cc)
char server[] = "arduino.cc";
char path[] = "/";
int port = 80; // 80 for HTTP

void setup()
{
  // initialize serial communications
  Serial.begin(9600);
  Serial.println("Starting Arduino web client.");
  // connection state
  boolean notConnected = true;

  // Start GSM shield
  // If your SIM has PIN, pass it as a parameter of begin() in quotes
  while(notConnected)
  {
    if((gsmAccess.begin(PINNUMBER)==GSM_READY) &
        (gprs.attachGPRS(GPRS_APN, GPRS_LOGIN, GPRS_PASSWORD)==GPRS_READY))
      notConnected = false;
    else
    {
      Serial.println("Not connected");
      delay(1000);
    }
  }

  Serial.println("connecting...");

  // if you get a connection, report back via serial:
  if (client.connect(server, port))
  {
    Serial.println("connected");
    // Make a HTTP request:
    client.print("GET ");
    client.print(path);
    client.println(" HTTP/1.0");
    client.println();
  } 
  else
  {
    // if you didn't get a connection to the server:
    Serial.println("connection failed");
  }
}

void loop()
{
  // if there are incoming bytes available 
  // from the server, read them and print them:
  if (client.available())
  {
    char c = client.read();
    Serial.print(c);
  }

  // if the server's disconnected, stop the client:
  if (!client.available() && !client.connected())
  {
    Serial.println();
    Serial.println("disconnecting.");
    client.stop();

    // do nothing forevermore:
    for(;;)
      ;
  }
}

My problem is that whenever I verify the code (using Arduino UNO on SDK 1.0.5), I get the following error:

gsmNet:25: error: 'GSMClient' does not name a type
gsmNet:26: error: 'GPRS' does not name a type
gsmNet.ino: In function 'void setup()':
gsmNet:48: error: invalid conversion from 'const char*' to 'long int'
gsmNet:48: error: initializing argument 1 of 'virtual int GSM::begin(long int)'
gsmNet:48: error: 'GSM_READY' was not declared in this scope
gsmNet:49: error: 'gprs' was not declared in this scope
gsmNet:49: error: 'GPRS_READY' was not declared in this scope
gsmNet:61: error: 'client' was not declared in this scope
gsmNet.ino: In function 'void loop()':
gsmNet:81: error: 'client' was not declared in this scope
gsmNet:88: error: 'client' was not declared in this scope

Do you have GSM folder in libraries folder?. Reinstall your Arduino SDK and check board selected is Arduino UNO.

yes i do and yes i made sure the selected board is arduino uno. i have read that the gsm library already installed with the SDK is outdated so i imported the new gsm library and i tested with both, the old and the new libraries..both give me same error

it works now…i only uninstalled arduino ide and downloaded the latest (version 1.5)