Can not login to web editor using google.

Tried to login using my Google account. Does not work. I tried several times. This is my first time trying to login. No joy. Just get a message saying roughly “it’s just one of those days”.

It appears that while I was not able to login using my google account your site did create an account for me. But, I still cannot login to the editor. It still gives me that hateful “It’s just one of those days”. message.

Hi @stonewolf,
we had some issues with our servers, please try again

Still not working for me. Didnt work last night either.

The team is working frantically to get us all back up

I have the same problem. Tried several days ago, still the same problem right now. I’m logged in with the Google account in this forum, but the web editor shows the “just one of these days” error every time.

Edit: now this was weird. Right after posting this, I switched back to the tab with the web editor, which previously wasn’t working on several tries, and it suddenly proceeded to load correctly. Glad to see it!