Can not upload using Web Editor.

When uploading using Web Editor, uploading is not possible. ALWAYS BUSY -_-…
However if use IDE, upload is possible.
Here is Arduino Create Agent ‘DEBUG’ message.

What is the problem?
Why is the port closed?

Windows 10 64bit (latest version)
use Chrome, Edge (latest version)
NO anti virus, ALLOW firewall

{"Version" : "1.1.86"} 
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]} 
{"Hostname" : "DESKTOP-PBU6MG0"} 
{"OS" : "windows"} 
downloadtool windows-drivers latest arduino keep
{"DownloadStatus":"Pending","Msg":"The tool is already present on the system"}
{"DownloadStatus":"Success","Msg":"Map Updated"}
downloadtool bossac 1.7.0 arduino keep
list
{ "Ports": [], "Network": true }
{ "Ports": [ { "Name": "COM5", "SerialNumber": "75430333137351A050B1", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.86", "NetworkPort": false, "VendorID": "0x2A03", "ProductID": "0x0043" } ], "Network": false }
close COM5
{"Error" : "We could not find the serial port COM5 that you were trying to close."}
{"DownloadStatus":"Pending","Msg":"The tool is already present on the system"}
{"DownloadStatus":"Success","Msg":"Map Updated"}
list
{ "Ports": [], "Network": true }
{ "Ports": [ { "Name": "COM5", "SerialNumber": "75430333137351A050B1", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.86", "NetworkPort": false, "VendorID": "0x2A03", "ProductID": "0x0043" } ], "Network": false }
list

Try restarting your computer.

A great post including most of the details needed but a couple of items missing if you would not mind.

Which particular board It says UNO in the picture so just checking ? Clone or true Arduino ? USB 3.0 or 2.0 ports ? Network type ( your own or a company / educational ) ?

Bob.

I am having similar problem.

Windows 7 Chrome, updated Mega, 2560 clone usb 2 private home network

My board uploaded fine prior to today with no problem on web editor. It currently works fine with IDE. Web editor recognizes and connects with board on COM12 but stays busy without end when attempting to upload, no error message. The board can also print to serial monitor on web with its current code, just can't upload via web.

This is from the debug console:

{"Version" : "1.1.86"} 
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]} 
{"Hostname" : "John-P50"} 
{"OS" : "windows"} 
list
{ "Ports": [ { "Name": "COM12", "SerialNumber": "75439333435351E02252", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.86", "NetworkPort": false, "VendorID": "0x2341", "ProductID": "0x0042" } ], "Network": false }
{ "Ports": [], "Network": true }

I have: checked port in device manager, changed com port manually, checked for updated driver, uninstalled and reinstalled arduino create plugin, restarted computer many times, changed usb ports, tried editor in firefox vs. chrome, disabled firewall and antivirus, double checked com port and board type, and even checked to see if other board types might somehow work.

I'm stumped. Please help.

thanks ~_~ It's same problem as me. I'll try to change port number manually. and i use 2560 Mega clone and R3 Uno true product.

Peplinskijohn: I am having similar problem.

Windows 7 Chrome, updated Mega, 2560 clone usb 2 private home network

My board uploaded fine prior to today with no problem on web editor. It currently works fine with IDE. Web editor recognizes and connects with board on COM12 but stays busy without end when attempting to upload, no error message. The board can also print to serial monitor on web with its current code, just can't upload via web.

This is from the debug console:

{"Version" : "1.1.86"} 
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]} 
{"Hostname" : "John-P50"} 
{"OS" : "windows"} 
list
{ "Ports": [ { "Name": "COM12", "SerialNumber": "75439333435351E02252", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.86", "NetworkPort": false, "VendorID": "0x2341", "ProductID": "0x0042" } ], "Network": false }
{ "Ports": [], "Network": true }

I have: checked port in device manager, changed com port manually, checked for updated driver, uninstalled and reinstalled arduino create plugin, restarted computer many times, changed usb ports, tried editor in firefox vs. chrome, disabled firewall and antivirus, double checked com port and board type, and even checked to see if other board types might somehow work.

I'm stumped. Please help.

I also can reproduce this issue. I have reported it to the Arduino developers. I'll post an update here if I have any new information to share.

I can confirm the same behavior…
No more than 7 days ago everything was fine. Using the web editor to upload to my meg2560…

Locally installed IDE works, just the web editor does not seem to work.
Tried it in Firefox, Chrome… Tried clearing local cache as well…

Tried re-installing the agent as well.

Happening on a Windows 10 System

Will try to duplicate this behavior on my Mac to see if this is platform specific.

Hi. The developers are asking for some additional information so they can investigate the issue. Please click on the tray icon for Arduino Create Agent. In the menu, it will show the agent version, something like this: “Agent version 1.1.86-5c199c1”. Please tell us which version is shown on your menu.

Thanks!

Same problem here the last few days, stays on "Busy" and not uploading. Did agent uninstall and reinstall, worked for a while, didn't help when i tried that again. Stopping and restarting the agent, reloading the browser, restarting the PC, nothing works.

Windows 10, 64 Bit Windows firewall OFF, no other firewall / antivirus installed USB 2.0 Agent version 1.1.86-5c199c1 Self managed network, Cable Modem, no F/W, no Proxy Chrome Version 73.0.3683.103 (Official Build) (64-bit) MKR WIFI 1010 with/without MKR ETH SHIELD MKR GSM 1400

{"Version" : "1.1.86"} 
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]} 
{"Hostname" : "OFFICE10"} 
{"OS" : "windows"} 
list
{ "Ports": [], "Network": true }
{ "Ports": [ { "Name": "COM12", "SerialNumber": "", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.86", "NetworkPort": false, "VendorID": "0x2341", "ProductID": "0x0054" } ], "Network": false }

Hello My agent version is "Agent version 1.1.86-5c199c1".

additionally it also does not work on Firefox... T.T

pert: Hi. The developers are asking for some additional information so they can investigate the issue. Please click on the tray icon for Arduino Create Agent. In the menu, it will show the agent version, something like this: "Agent version 1.1.86-5c199c1". Please tell us which version is shown on your menu.

Thanks!

Similar thing happening to me.

Tried with an UNO R3 and an UNO Wifi R2.

Code is verifying fine, offline IDE seems to be working fine, but web editor won't upload. Rx/Tx lights aren't lighting up on either board, so it seems like web editor isn't working with my COM3 port :(

I'll check firewall settings and stuff.

For those wanting specs:

Using via Chrome

Windows 10

USB 2

Private home network

No error message, just won't even start uploading.

-BW

Thanks for the information Baggage_warrior! Please tell us which version of the Arduino Create Agent you're using:

Please click on the tray icon for Arduino Create Agent. In the menu, it will show the agent version, something like this: "Agent version 1.1.86-5c199c1".

Agent version 1.1.86-5c199c1

Sorry for missing that part out...

-BW

Same version of Arduino Agent for me on Windows 10...

1.1.86-5c199c1...

Meanwhile i verified that the web editor and arduino agent works fine on my Mac Mojave with the same version of the agent.

Same here. 1.1.86-5c199c1

Thanks for following up

Please note that I split the TAB issues into a seperate post. If you have that problem please add it to that one.

Bob.

I noticed the following error on Chrome's console:

jquery-3.3.1.min.js:2 Cross-Origin Read Blocking (CORB) blocked cross-origin response https://forum.arduino.cc/index.php?api&pm&json with MIME type application/json...

So I started Chrome with a flag to disable the security check:

chrome.exe --user-data-dir="C:/Chrome dev session" --disable-web-security

And then I noticed an issue which looks related to bossac.exe:

Create file C:\Users\Admin.arduino-create\arduino\bossac\1.7.0: open C:\Users\Admin.arduino-create\arduino\bossac\1.7.0: is a directory"

Manually placing bossac.exe in that directory didn't help as the agent keeps on recreating the directory structure.

Obviously this is not a professional debug process but perhaps can help someone investigating the issue.

Uninstalled and reinstalled agent (choose “only Chrome and Firefox”).

Win 10 64 Enterprise V1803, OS17134.706
Chrome Version 73.0.3683.103 (Official Build) (64-bit)
Agent 1.1.86-5c199c1

Tried with:
Arduino Nano (clone)
Eelegoo Mega 2560
Mega 2560 mini pro

When I plug in the Eelegoo Mega 2560 I get this log:

{"Version" : "1.1.86"} 
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]} 
{"Hostname" : "HP-FOLIO-1020-R"} 
{"OS" : "windows"} 
list
{ "Ports": [], "Network": true }
{ "Ports": [ { "Name": "COM6", "SerialNumber": "95634303432351917201", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.86", "NetworkPort": false, "VendorID": "0x2341", "ProductID": "0x0042" } ], "Network": false }
list

Serial monitor works fine. Code compiles, but when trying to upload it just freeze in “busy”.

Please let me know what other info might be useful.

Same problem, stays on “Busy” and not uploading.

Windows 10, 64 Bit
Windows firewalll / antivirus installed
USB 2.0
Agent version 1.1.86-5c199c1
Self managed network, Wi-Fi, no Proxy
Firefox 66.0.3 (64-bit)
Arduino Uno R3

{"Version" : "1.1.86"}
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]}
{"Hostname" : "KINKPUNK"}
{"OS" : "windows"}
list
{ "Ports": [], "Network": true }
{ "Ports": [ { "Name": "COM7", "SerialNumber": "7573530303135111F111", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.86", "NetworkPort": false, "VendorID": "0x2341", "ProductID": "0x0043" } ], "Network": false }

Hi, Same for me,

Windows 10, 64 Bit Windows firewall/antivirus USB 2.0 Agent version 1.1.86-5c199c1 Self-managed network, Wi-Fi, no Proxy Chrome (Chromium: 73.0.3683.103 (Official Build) (64-bit))

{"Version" : "1.1.86"} 
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]} 
{"Hostname" : "Fredgo"} 
{"OS" : "windows"} 
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
{
    "Ports": [],
    "Network": true
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}
list
{
    "Ports": [],
    "Network": true
}
{
    "Ports": [
        {
            "Name": "COM3",
            "SerialNumber": "55731323835351514071",
            "DeviceClass": "",
            "IsOpen": false,
            "IsPrimary": false,
            "Baud": 0,
            "BufferAlgorithm": "",
            "Ver": "1.1.86",
            "NetworkPort": false,
            "VendorID": "0x2341",
            "ProductID": "0x0043"
        }
    ],
    "Network": false
}