Can program only once

Hi there,

I’m really frustrated as I spend several useless hours without any progress

  1. using a Mega2560 compatible board
  2. upload fails with “avrdude: stk500v2_ReceiveMessage(): timeout” message. This was discussed in the web several times but the proposals didn’t solve my issues. I also tried to program from two different computer with not success
  3. I’ using a Arduino Uno and programmed the “Arduino as ISP” in order to write new bootloader
  4. then I can program any program exactly once
  5. next time programming fails with the above message

For me it sounds like programming the uC does override the bootloader??

Has anyone a idea and can tell me which fuses I have to set (have a STK500 and USBasp available as well)?
Maybe I’m doing something very easy thing wrong?!?!?!

Thanks

Timo

Tell us how you are programming the bootloader (in your own words)

  • solved -

Hi,

seems it was a classical mistake from my side and I paid a high price for this learning lessons: =(

As I'm using a MEGA2560 derivate (HK MultiWii board) and damaged my USB connector (which is connected to CP2102) I had to use another external CP2102 and wired it to the Rx/Tx lines. I read a lot about entering programming load, but didn't realize how to make this effective (giving the control to the serial converter). Also my external CP2102 board didn't have the DTR connected to a pin... It came to my mind that I have a Foca-programming board somewhere and it worked fine (wiring all pins incl DTR!)! tested now to program several code and all looks good!

It's only strange why after burning the bootloader, I was still able to program once the chip but suspect, that on a "blank" chip only having the BL burned, it would expect a program to be written hence I was able to write.

However - lessons learned, issue fixed.

Thanks to all putting their brain in my problem :-)

Timo