can;t get newly installed IDE to upload

I am very new to all this. I have just downloaded the IDE for windows. I loaded the blink sketch and tried to upload it - it failed. Have selected the correct board but the port label is greyed out. the error msg talked about and error while attempting to upload. tried to install the .inf file but got a message about one of the installers being unable to run at that stage. Have tried to read the installation problems thread (some of which is over my head). The UNO board is plugged in and the ON led and the Led connected to pin 13 is also on. Can anyone help = please!!

What does the device manager say? If you bought a clone, you might need the CH340 drivers; do a search here.

Thanks for your reply. The Device Manager shows "other devices - unknown device". when I try to install the driver it shows "one of the installers for this device cannot perform the installation at this time" but it also shows that a driver for this device has been found. I downloaded a driver for the CH340 and it installs but cannot link to the device (board)? Still completely lost. Does it make any difference that I'm running Windows 10

Depending on the OS installation type you might have driver enforcement turned on.
Worth looking that up on google and turning off to re-do a driver installation.

Also the CH 340 drivers should be from HERE

You may find some bad CH340 drivers from other sources.

Great advice but unfortunately the problem remains. That was the site I used. Tried turning off the driver enforcement but still get exactly the same error message. Really desperate now. $200.00 of down the drain??? If it was the driver enforcement would the other drivers in the folder load because they do.

Oh well it was a nice dream - pity it looks like its been a waste of time and money - nothing I try works the devices show on device manager but the IDE still has ports greyed out and the drivers won't load time to give up and regret getting involved. pity as the grandkids showed a lot of interest

Going to suggest something quite radical.

There is a post HERE that I would like you to read and then give as much info as you can back here.

Please take a few moments to Learn and Use the Forum.

Get the best out of this forum Installation & Troubleshooting

Hello, Welcome to the Arduino Forum. This guide explains how to get the best out of this forum. Please read and follow the instructions below. Being new here you might think this is having rules for the sake of rules, but that is not the case. If you don’t follow the guidelines all that happens is there is a long exchange of posts while we try to get you to tell us what we need in order to help you, which is frustrating for you and frustrating for us. The people who try to help with your pro…

It will help you get the very best out of the forum in the future.

  • Mention if you are using AI generated code it is important information.
  • Your OS and version can be valuable information, please include it along with extra security you are using. Antivirus etc.
  • Always list the version of the IDE you are using and the board version if applicable.
  • Use quote or CODE tags to add error messages as an attachment NOT a picture.
  • How to insert an image into your post. ( Thanks sterretje )
  • Add your sketch where applicable but please use CODE TAGS
  • Add a SCHEMATIC were needed even if it is hand drawn.
  • Add working links to any specific hardware as needed (NOT links to similar items)
  • Remember that the people trying to help cannot see your problem so give as much information as you can


  • Ensure you have FULLY inserted the USB cables.
  • Check you have a COMMON GROUND where required. ( Thanks Perry)
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • You may not have the correct driver installed. CH340/341 or CP2102 or FT232 VCP Drivers - FTDI
  • There may be a problem with the board check or remove your wiring first.
  • Remove any items connected to pins 0 and 1.


  • Close any other serial programs before opening the IDE.
  • Ensure you turn off any additional security / antivirus just to test.
  • There may be a problem with the PC try RESTARTING it.
  • You may be selecting the wrong COM port.
  • Avoid cloud/network based installations where possible OR ensure your Network/Cloud software is RUNNING.
  • Clear your browsers CACHE.
  • Close the IDE before using any other serial programs.
  • Preferably install IDE’s as ADMINISTRATOR or your OS equivalent


  • CH340/341 based clones do not report useful information to the “get board info” button.
  • NANO (Old Types) some require you to use the OLD BOOTLOADER option.
  • NANO (ALL Types) See the specific sections lower in the forum.
  • NANO (NEW Types) Install your board CORE’s.
  • Unless using EXTERNAL PROGRAMMERS please leave the IDE selection at default “AVRISP mkII”.
  • Boards using a MICRO USB connector need a cable that is both DATA and CHARGE. Many are CHARGE ONLY.

CREATE editor install locations.

  • On macOs ~/Applications/ArduinoCreateAgent-1.1/
  • On Linux ~/ArduinoCreateAgent-1.1/config.ini
  • On Windows C:\Users[your user]\AppData\Roaming\ArduinoCreateAgent-1.1

Performing the above actions may help resolve your problem without further help.

Language problem ?

Try a language closer to your native language:

Thanks to all those who helped and added to this list.

I think we may be missing something simple but until we know as much as possible its hard to know.

Most non connection issues to a board often turn out to be something simple.

OK I'll try...
I'm using a Toshiba Laptop running Windows 10. Its running a AMD A4 5000 APU 64bit.

I have down loaded the IDE of the Arduino web site and it runs fine except that the Tool -Ports is greyed out. I have tried starting the IDE with the Board plugged in and plugging it once the IDE is running no difference. I have selected the uno and the screen shows it is looking for a Uno on COM 1.

I have been into the device manager and it shows an unknown device port #003 Hub #001. This changes depending which of the three USB ports it is plugged into. The screen also says "This device is not configured correctly (code 1)". I have used the update driver option and the following message is shown

"windows found software for your device but encountered an error while attempting to install...

Arduino Uno

One of the installers for the device cannot perform the installation at this time"

When the board is plugged in both lights (on/power and L attached to pin 13) are lit (neither blinks)

Its a clone Duinotech Uno is about all I Know.

I'm beginning to wonder if there is a problem with my computer - corrupted windows file????

That's about all I know. But if you need more info I more than happy to provide.

I have been researching but none of the solutions match my problem

Hope this helps at your end - thank you for your being there - can't wait for your response

I would send you screen prints but I don't know how to get them?!

The CH340 drivers are a red herring for that board as it is not a clone as we know it.

I am thinking USB 3.0 ports might be the issue.
Do you have access to an older computer with a USB 2.0 port ?
That would be my line of attack on this problem.
Some of us have also had success with a "POWERED USB 2.0" hub between USB 3.0 ports and the Arduino.

Either of those methods may rule out the board as a problem.

Those that are true to the Arduino design can be susceptible to damage of the serial chip (16U2) with over-voltage and they continue to be reports of them in the forum also with voltage regulator issues too.

If you use external power try keep it below 10 volts or less regardless of the recommendation of 5 - 12 volt.

Screen prints are easy in windows (google is your best friend)
Attaching them here is the harder part as there are size restrictions and a few hoops to jump through.

Why do you suspect a corrupted windows file ?
BTW best bet in windows is to install as an administrator as the success rate is much higher for a working IDE.
And turning off driver enforcement is also a good bet with Arduinos and windows.

Reasons seem to imply that some security software may allow a normal install if run at an ADMIN level.

Oh Yeah!!!

I have a old computer running windows xt. It was going to the dump but I never got around to getting all the stuff of it - being lazy pays off sometimes. Any way, I managed to download the IDE - plugged in the board and there it was - can't believe how great it was to see a LED flash after uploading the blink sketch. Faith restored.

However that leaves the question of how to get back onto the laptop.
I considered the corrupted windows for 3 reasons

  1. The IDE is completely unaware that there are usb ports on this computer
  2. I have a number of updates that I can't download/install and my efforts to resolve the issue have gone no where to date.
  3. A guy I spoke to had a similar problem (couldn't install drivers - got the same error msg). In the end he backed up his data reformatted the disk and started again - problem solved. By the way I can't see my wife letting that happen.

Tried turning off the driver enforcement - no effect. I also turned off all security stuff before I reinstalled the IDE. Don't fully understand the administrator thing but I'm researching it.

Don't get the powered USB 2 thing - I assume its a piece of hardware that plugs into the USB port and the board plugs into that. If that's the case intuitively can not see how that helps as the IDE is not aware that there are any ports existing but I will research that too.

Thank you so much - nearly gave up. I am a bit surprised the old computer even ran let alone downloaded the IDE = very slowly

If you have any further thoughts on getting it to run on the Toshiba I would love to here them.

Regards and thanks - Brian R (blr3621)

Your last post was the clincher.

No USB ports then no Arduinos !

Have you run the Toshiba diagnostics as they would tell you if there were any driver updates for the lappy.

Best of luck getting it to work and hope you find a fix for the tosh.

I think you may have missed the point

Problem 1
The USB ports are there and they show the board in the Device Manager - the IDE cannot see them (because they are not called COM?)

Problem 2
For some reason I can not install some drivers. I just get the error message posted before

Some drivers are fine while others fail

On some installations of windows 10 the COM ports are under HIDDEN DEVICES and its view must be enabled.

Then you should see "Ports ( COM & LPT )".

OK Will try to find them and un-hide them.
I uploaded a small bit of my project to try it - went very well. Quite exciting to write some code and see it come to life. Old computer is a bit slow though.

My hunch seems to be correct - there was a problem with the computer!

Last night got a large download from Microsoft upgrading Windows 10. This morning the Device Manager shows Ports and show the Uno on one of them. The IDE is happy and the ports bar is active and shows the board. Just uploaded my first (on this computer) - no problems. Can put the old (and slow) computer to sleep again.


Good to hear you are up and running.

Thank you so much for your help. Your patience, expertise and encouragement is appriciated