Can’t get WiFiNINA firmware updated to version 1.4.8

Hardware: Arduino MKR WiFi 1010, powered by USB.
Problem: Can’t get WiFiNINA firmware updated to version 1.4.8 using the IoT Cloud editor and the IDE (v1.8.15) will only update it to version 1.4.5 (the highest version listed).
I purchased the Opla IoT Kit and one of the last steps in “Part 2 Setting Up The Arduino IoT Cloud” fails. In the “Gradually building code” section when I try to upload the code to the board it says NINA firmware update is required. When I click ‘Update’ it detects my MKR1010 board okay and states “ready to be updated”. However when I click ‘Continue’ it starts “checking firmware” and then goes to “We were not able to update the firmware”. I have the ‘Sketch’ tab open and (as suggested elsewhere) I’m NOT using the Full Editor and I also tried restarting Create Agent as suggested but nothing works so far.
I think my MKR1010 board and cables etc are all fine because I can update the WiFiNINA firmware using the IDE (v1.8.15) by loading File -> Examples -> WiFiNINA -> Tools -> FirmwareUpdater and then running Tools -> “WiFi101 / WiFiNINA Firmware Updater”. I can select my COM port okay and select “NINA firmware (1.4.5)” which is the highest choice offered, and when I click “Update Firmware” it all works and I get “The firmware has been updated” message. HOWEVER when I load and run ‘CheckFirmwareVersion’ it confirms that version 1.4.5 is installed BUT also reports that the latest version is 1.4.8! I looked all over, where is that version and how can I get that version loaded?
What am I doing wrong? It won’t let me complete “Part 2 Setting Up The Arduino IoT Cloud” until the WiFiNINA firmware is updated. Thank you.

The reason Arduino IDE 1.8.15 only has NINA firmware version 1.4.5 is because Arduino IDE 1.8.15 was released some months ago and that was the newest version of the firmware at the time of the IDE release. In this current very active phase of the NINA firmware development when there are a lot of new releases being made, the strategy of distributing it via Arduino IDE releases is not very effective. There is work in progress to improve on this situation in the beta phase Arduino IDE 2.x:

This shows that the situation will improve eventually, but it doesn't provide you with an immediate solution.

What will provide you with an immediate solution is to download the hourly build of the Arduino IDE:
https://www.arduino.cc/en/software#hourly-builds
This contains the latest 1.4.8 version of the NINA firmware. Once you have downloaded and extracted the hourly build of the Arduino IDE, just start it up and follow the standard firmware update process as described here:

Once you have finished updating the firmware, there is no need for you to continue using the hourly build of the Arduino IDE if you prefer to go back to 1.8.15 or Arduino Web Editor. The hourly build of the IDE is just a convenient way to get the latest firmware version. After that, you can delete it if you like.

Thank you very much. Your explanation was clear and your procedure worked perfectly. It is all working now!

I responded on the Forum and checked the SOLUTION box but I’m new to the Forum (and Arduino) so let me know if I incorrectly responded there. It is all working now! Thanks again. - Vince

You're welcome. I'm glad to hear it's working now.

Thank you for taking the time to use the forum's "solution" feature. I think this can be useful to help others with the same question find the answer in the massive amount of information that is the Arduino Forum, and also perhaps indicate to the helpers here that they can focus their attention on other forum topics. Usually people will mark the reply that contained the solution, but I don't think anyone here is too uptight about how it's used so long as it's done with good intent.