Can´t upload any code. Help please.


my Arduino isn´t working any more. I can´t upload any new code and I can´t see the Arduino on the device manager. I have tried the troubleshooting: restarting the Arduino and the PC, unplug and plug the Arduino, taking off the PC power source, pressing the reset botton when uploading, etc. Nothings seems to be working.

I also tried with other Arduinos connected to my PC and they work propertly. So I don´t think this isn't a drivers problem.

My PC runs Windows 7. Help please. Thanks!

Is the "Arduino" an UNO or MEGA? If so you may need to re-install the USB-to-Serial firmware:

Hi Johnwasser,

i am using an Arduino UNO which I bought a few days ago, so in theory it should be the newer version.

You were right and the problem now seems to be solved. But I am now puzzled because I only downloaded the DFU programmer. I didn´t down download however de firmware update and didn´t reset using 8u2.

Is there a way that by only downloading the DFU programmer the problem was solved?


Is there a way that by only downloading the DFU programmer the problem was solved?

I don't think so. o.0

Me too has the same problem. My Arduino Mega2560 is not getting recognised by the computer.
I could not even see it in the device manager.

Can you please tell me how did u solve the problem?

The problem was back! However, I think I know now what the issue was for certain. To fix the Arduino to my robot chasis I used some metallic nuts what were in thouch with the base of the board. They in fact were causing all this problem.

To follow the steps in the link you johnwasser sent me I took the board off the robot chasis. Then the board started working even the fact that I coudn´t follow all the steps in that link, just because the board wasn´t touching metal any more.

Thanks johnwasser for all your help as always. And good luck vishnuX in solving your problem as well.

Arduino UNO
this might help u. A good one, I felt.