Cannot access Editor

Hello, I use arduino create to teach robotics at my school and one of my students can no longer access the web editor. They are able to login to their account however when they try to open the editor it always redirects to the last sketch they had opened in preview mode. They try to add it to their sketchbook and it gives the error saying they cannot since the name is already in use. We have tried multiple browsers/computers etc and the issue is always the same. Regardless changing the url or click the icon for the editor from the website, it always tries to open the last sketch in preview mode. There is no way to get to the editor itself to make a new sketch, see old sketchs, etc.

I have a handful of students who are having the same problem.

I have same problem. I tried cleaning cache / changing web browsers(chrome and edge)/ access from other PCs, but it's not solved.

Hi all. Sorry for the trouble with the Arduino Web Editor. The problem should be fixed now. Please give it another try and let us know if you still have any problems.