Cannot access my profile

'Loading' appears in the upper left of the screen but nothing else ever happens.

If that on the web site or the online editor or something else ?

Also try with any browser add ons turned off
If you are using Chrome then try in an "incognito" window

Other browsers have similar abilities to chrome.
Just to rule out the browser as being at issue.

After that try with some of your computers security turned off eg antivirus (just for a quick test only)

ballscrewbob:
If that on the web site or the online editor or something else ?

The website where we're having this conversation.

ballscrewbob:
Also try with any browser add ons turned off
If you are using Chrome then try in an "incognito" window

Other browsers have similar abilities to chrome.
Just to rule out the browser as being at issue.

Shut off IE 11 add-ons one by one. No joy.

ballscrewbob:
After that try with some of your computers security turned off eg antivirus (just for a quick test only)

Turned off av, no joy.

Your mention of Chrome prompted me to try an experiment. Started Chrome, logged in and was immediately able to access the profile page. I guess it's an IE thing? I was going to try Firefox also but my copy seems to have been damaged.

Anyhow, it's clunky but I can get to my profile if needed. Thanks.

I haven't used IE11 in a long time.

However there are a couple of things you can try.

Download CCLEANER (free version).
Install it.
Run it (Analyse) but don't change any settings.
Then select the "Run Cleaner" option.

See if that improves things

Failing that open IE11
Select the little gear top right.
Click "Internet Options"
In the box that opens select "Advanced"
Click "RESET" at the bottom. (It may take a minute or two and there might be another prompt to agree to)
Then try again to get to your profile.

Thanks for the tips. I'll let you know the results.