cannot compile any code on my IDE , on windows 8

Arduino: 1.8.3 (Windows 8), Board: "Arduino/Genuino Uno"

E:\arduino\arduino-1.8.3\arduino-builder -dump-prefs -logger=machine -hardware E:\arduino\arduino-1.8.3\hardware -tools E:\arduino\arduino-1.8.3\tools-builder -tools E:\arduino\arduino-1.8.3\hardware\tools\avr -built-in-libraries E:\arduino\arduino-1.8.3\libraries -libraries E:\arduino\arduino-1.8.3\portable\sketchbook\libraries -fqbn=arduino:avr:uno -ide-version=10803 -build-path C:\Users\charuka\AppData\Local\Temp\arduino_build_162048 -warnings=none -build-cache C:\Users\charuka\AppData\Local\Temp\arduino_cache_724449 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=E:\arduino\arduino-1.8.3\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=E:\arduino\arduino-1.8.3\hardware\tools\avr -prefs=runtime.tools.avrdude.path=E:\arduino\arduino-1.8.3\hardware\tools\avr -verbose E:\arduino\arduino-1.8.3\examples\01.Basics\Blink\Blink.ino
E:\arduino\arduino-1.8.3\arduino-builder -compile -logger=machine -hardware E:\arduino\arduino-1.8.3\hardware -tools E:\arduino\arduino-1.8.3\tools-builder -tools E:\arduino\arduino-1.8.3\hardware\tools\avr -built-in-libraries E:\arduino\arduino-1.8.3\libraries -libraries E:\arduino\arduino-1.8.3\portable\sketchbook\libraries -fqbn=arduino:avr:uno -ide-version=10803 -build-path C:\Users\charuka\AppData\Local\Temp\arduino_build_162048 -warnings=none -build-cache C:\Users\charuka\AppData\Local\Temp\arduino_cache_724449 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=E:\arduino\arduino-1.8.3\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=E:\arduino\arduino-1.8.3\hardware\tools\avr -prefs=runtime.tools.avrdude.path=E:\arduino\arduino-1.8.3\hardware\tools\avr -verbose E:\arduino\arduino-1.8.3\examples\01.Basics\Blink\Blink.ino
Using board 'uno' from platform in folder: E:\arduino\arduino-1.8.3\hardware\arduino\avr
Using core 'arduino' from platform in folder: E:\arduino\arduino-1.8.3\hardware\arduino\avr
Detecting libraries used...
"E:\arduino\arduino-1.8.3\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10803 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IE:\arduino\arduino-1.8.3\hardware\arduino\avr\cores\arduino" "-IE:\arduino\arduino-1.8.3\hardware\arduino\avr\variants\standard" "C:\Users\charuka\AppData\Local\Temp\arduino_build_162048\sketch\Blink.ino.cpp" -o "nul"
Generating function prototypes...
"E:\arduino\arduino-1.8.3\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10803 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IE:\arduino\arduino-1.8.3\hardware\arduino\avr\cores\arduino" "-IE:\arduino\arduino-1.8.3\hardware\arduino\avr\variants\standard" "C:\Users\charuka\AppData\Local\Temp\arduino_build_162048\sketch\Blink.ino.cpp" -o "C:\Users\charuka\AppData\Local\Temp\arduino_build_162048\preproc\ctags_target_for_gcc_minus_e.cpp"
fork/exec E:\arduino\arduino-1.8.3\hardware\tools\avr/bin/avr-g++.exe: Access is denied.
Error compiling for board Arduino/Genuino Uno.

Looks like an access control problem. Perhaps re-installing the IDE will fix it.

On Windows delete or rename these directories:
Arduino IDE 1.6.5r5 and previous: C:\Users(username)\AppData\Roaming\Arduino15
Arduino IDE 1.6.6 and later: C:\Users(username)\AppData\Local\Arduino15

Then re-install the IDE.