Cannot compile even the blink sketch

I had used Arduino UNO about 3 years ago and it was working fine. I could not work on it as I got busy. I wanted to restart my projects and I downloaded the latest IDE 1.8.5. Even the blink sketch example would not compile. I tried many times. It would compile a few times and loads on the arduino. I wanted to start with a clean IDE so I deleted all the old software and downloaded the new IDE 1.8.5. Now it does not compile at all.
My software is located on a Dell Vostro laptop using OS: WINDOWS 7. I am using Arduino UNO and Port: COM4 on USB.
Attached file gives the result of compilation error.
Any help in fixing the problem will be greatly appreciated.

My email: (redacted)

Arduino.txt (1.08 KB)

Sketch uses 928 bytes (2%) of program storage space. Maximum is 32256 bytes. Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.

That means you had a successful compile. You're not having a problem compiling.

Your computer has a problem communicating with the board to do the upload. That error has only been posted here about ten million times so far this year. Try searching and seeing if you can't find the solution.

BTW: It is incredibly foolish to put your email address in plain text on the internet unless you are trying to be a magnet for spam. Folks here will post the answers here, not your email. Your email doesn't help you get anything but abuse from the less savory members of the internet community.

Thank you Shannon Member for your information. I tried a new cable and changed the USB port and it works sometimes. If I keep repeating it works sometimes and sometimes not. May be my computer is not communicating properly on USB. I am new to this forum therefore I did a foolish thing in giving my email address. I'll try and filter the emails. One more request. How do I search for the potential solutions that you suggested here? I would appreciate very much. Thank you again

How do I search for the potential solutions that you suggested here?

Follow this link, it will show you what to do.

Not sure what I was looking at Delta.

Not sure what you're on about there Bob. That link works fine for me.

Thats what I was fed from the page. Still see it in latest chrome.

No prob.

Crazy. It's just a lmgtfy link.