Cannot connect Nano 33 IoT to IoT Cloud

I am trying to connect my Nano 33 IoT board to the Arduino IoT Cloud, but every time I tried to connect, it kept giving me the feedback of "We were not able to update the firmware, Cannot read property 'latest_wifi_fw_version' of undefined."

I tried various methods of updating the WiFiNina firmwares, but it does not seem to resolve the issue. Please help.


Hi @lilegend124 there was a report about the same problem a couple weeks ago. In the end, it turned out that their antivirus software had quarantined the FirmwareUpdater program that must be installed on your computer to allow Arduino IoT Cloud to update the firmware on the NINA-W102 Wi-Fi module on the Nano 33 IoT when it is found to be outdated

Yes, I've read that post and also attempted to find the file. For my case, the file became a hidden file for some reason instead of getting blocked by the antivirus, I unchecked the 'hidden' option and now the file is no longer hidden. However, the same issue still remains.

I've also checked out this post

and cloned the fwuploader from git-hub, but again, the same issue still remains. I also can't update to the newest version from the IDE as the post states. Are there any other alternative solutions?
@pert