Cannot find /dev/tty.usbserial

Hi there, I have just bought a new Uno board (clone), however, it is not showing up in the "Tools" of the IDE for connect to.

I have already installed the drivers from:

http://www.wch.cn/downloads.php?name=pro&proid=178

And prolific drivers from:

https://s3.amazonaws.com/plugable/bin/PL2303/PL2303_MacOSX_10_6_and_newer_v1_5_1.zip

However the tty.usbserial is still not showing up under /dev/tty.* and that means I cannot connect to Uno at all.

Need help on this please.

Post a picture of your board or a link to where you got it from so we can advise on which drivers are needed.

Also what OS have you got? (Linux or Mac).

Oh and what does dmesg show as a result of the board being plugged in?

Thanks for helping out. I have attached photo of the Uno board, and I am working on a Mac OS X 10.7

This is the board:

Imgur

I bought the board from this site

Link to the item description:

http://m.aliexpress.com/item-desc/1207142899.html

I have installed 340/341CH drivers. When I plug in the Uno board, terminal (dmesg) didn't show anything new or message.

What I have done is to install the CH340/341 drivers, and ran a sudo code below:

sudo nvram boot-args=“kext-dev-mode=1”

Followed by rebooting my macbook air.

When I run “tools/ports” on the Arduino IDE, I cannot find the dev.tty.usbserial

The solution was sourced from:
https://www.blogger.com/comment.do?loginRedirect=ixbnpksBAAA.7VzJFYWmNOLxo55dPEQb_HbGNyqse9zKLNtBO7Pq_Sw.TCm6OIGPkdDEdAoHoElhLg&pli=1

Screen Shot 2015-02-20 at 12.13.09 PM.png

Any able to advice?

I checked console with the arduino plugged in, it says

=====

21/2/15 2:12:35.000 pm kernel[0]: USBF: 705.876 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 2 of Hub at 0xfd100000)
21/2/15 2:12:35.000 pm kernel[0]: USBF: 706.178 The IOUSBFamily was not able to enumerate a device.

See this thread here for getting the CH340 working on a Mac.