Cannot get Board Manager to show the microcontrollers attiny84 and 85

Had to reload because of hard disk failure and now cannot find how to get Arduino to program the Attiny84. The address for the boards in preferences is probably wrtong because I cannot fine it again. What is my problem?

Please follow these instructions:

If you run into any problems, come back with a detailed description and I'm sure we'll be able to help you out.

I have tried entering the board manager URL in Preferences then going to tools and Board Manager. New items are downloaded into Board Manager but none show up for programming the attiny 84 (using UNO as ISP).

The manual option said to download the zip and follow your instructions. I couldn't find a zip address.

Everything worked fine before with a long, long board URL which is what I can't find in my notes.

Do this:

  • Tools > Board > Boards Manager
  • Wait for downloads to finish
  • Scroll the window down until you see the entry titled "ATTinyCore by Spence Konde". Click on it.
  • Click "Install".
  • Wait for installation to finish.
  • Click "Close".

You will now find new boards in the Tools > Board menu: "ATtiny24/44/84" and "ATtiny25/45/85".

Have followed instructions to the letter but still no luck. I get an error that says "error in downloading http://drazzy.com/package_drazzy.com_index.json and the board manager shows only the initial items which came in the IDE download.

I am trying to use the Arduino Uno to program the attiny 84V, 85. Is there a different board URL for this function?

I have to apologize for my last try. I had an error in typing and my eyesight didn't catch it. When I found it and corrected it everything started doing as you told me. Sorry but thank you very much for the help.

I'm glad to hear you found the solution! Have you been able to upload to your ATtiny84 or ATtiny85 yet?