Cannot get Ethernet Shield to work

Using WebClient code that came with Arduino and samples downloaded from this forum. Router does not see ethernet shield. Tried DHCP and static, with and without gateway and subnet mask. Tried second ethenet shield, no change. Tried another cable, no change. Tried different router, no change. Routers - Linksys (old) and 2Wire (current.) Firewall settings all open for inside connections, even added MAC as specifically allowed.

Any magic other than plugging the boards together, uploading the code with address changes, and watching the serial monitor? All the board lights blink nicely as if doing something meaningful.

No magic. You've tried all the right stuff. Do any of the other Ethernet example sketches show signs of life? Maybe DHCPAddressPrinter?


amazing, the DHCP address printer worked out of the box on the Linksys but not on the 2Wire. Only difference was the MAC address provided in this code from the WebClient code. changed the MAC in WebClient, now talking to the router. But Linksys not on internet - do i really want to recofigure the house for the linksys over the supposedly newer and better wireless 2Wire? hmmmmmmmmmmmmmmm.

Thank you.


You can try surfertim’s test code to see if you get qan assigned ip address.

#include <SPI.h>
#include <Ethernet.h>

byte mac[] = { 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };

void setup()

  // disable SD SPI if memory card in the uSD slot

  Serial.println("Starting w5100...");
  if(!Ethernet.begin(mac)) Serial.println("failed");
  else Serial.println(Ethernet.localIP());

void loop() {


Hello, how is the setup of your router DHCP?

Try to find the equivalent info of linksys screenshots on your 2wire router to check..