Cannot install a new board

I like to program a m%stack Atom NB IOT...

I tried in preferences/additional boards the following url:

No additional boards show up, even after restart and re-install of IDE 2.0

What am I doing wrong?

After adding the json file links did you use the Boards Manager to actually install the boards ?

The boards did not show up in the boards manager...

But it showed up under the board selection, then asked to install the board manager file manually, which it did, got the board selected with a yellow exclation mark but now I tried an example and got the following error:
Compilation error: Missing FQBN (Fully Qualified Board Name)}

Selected M5Stick-C and it works...

Thank you for the help here.

This bug is being tracked by the Arduino IDE developers here:

This is meant by the IDE to communicate that the board could not be automatically identified from the port. That is a normal and expected state of affairs for a board like the M5Stack that uses a general purpose USB chip without a custom VID/PID pair. It only means that you must select the correct port yourself.

I'm glad to hear it!

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.