cannot install Arduino IDE on RPi4

RPi4 Buster
I downloaded and extracted the tar.
I typed sudo ./install.sh from within the arduino-1.8.10 directory.
I got a "done!" from the script.
I got an arduino icon on the desktop.
I click the icon, and I get an hourglass for a moment, then nothing. The IDE never starts.

this recipe worked for the RPi 3 with stretch.

I tried both the linux64 tar and the arm linux64 tar....same issue.

I know this is something incredibly simple, so please let me know your thoughts, even if it seems glaringly obvious.
thx
MrLessismore

Did you try the “Linux ARM 32 bits” download?

I just tried the Linux ARM 32 bits download and had the same results. I did uninstall the 64bit tar first.
I will keep poking around.

Ok I have some sucess with this site

I substituted:
sudo tar xvJf arduino-1.8.10-linuxarm.tar.xz -C /opt
instead of the author's exact instruction.

I got a strange message when I clicked the desktop icon...I got a box that told me the file was executable and did I want to execute it? or execute it in terminal...weird
I clicked execute it and it did start the IDE
I cruised around the IDE and it seems to work. The library manager opened with all the library choices...
I would call it a win.

I’m glad to hear it’s working now. Enjoy!