Cannot install driver

I have the Duino JR. kit. I installed the software as instructed. I tried running the software on a new macbook air- could not get it to work. Read somewhere that it is an issue with the mac.

Installed the software on an older pc running win 7 64 bit. - The computer does not recognize the duino. In device manager I get an unknown, where the name should come up. Tried downloading 3 different drivers that were recommended in this forum. Non of them worked.

I do not know what else to do. I feel like whatever computer I try there is some kind of an issue with the software or hardware.

Mac would be my first choice if there is a way to get it to work, but I can settle for windows.

Please help.

  1. Where exactly did you buy the kit (link?) ?
  2. Could you post a clear picture with front and back side of your Arduino, so we might identify the USB communication chip which seems to cause the trouble

Following find a link which explains how to make images visible in your postings:

First, I would like to thank you for taking the time to help me.

I purchased the kit from scientific direct.com.



I was not able to add the photos in the thread. When I try to right click on the link the photo is automatically downloaded on a mac.

IMG_0832.JPG

Had a look at an unboxing tutorial of your Jr kit.
So the kit is working with a nano clone apparently.

This is the little board with the USB connector on it. It is placed in a 30 pin header socket.
So what you should do now is:

  1. Disconnect the Nano from the PC/laptop and make sure there is no other power connected to the kit
  2. With a little bit of “cautious force” you can lift the Nano off of the socket. A screwdriver placed under the Nano, starting on one side, lift a bit, go the other side, lift to the same level etc. will support you.
  3. Turn the Nano over and have a look at the back side. There is a chip with either 20 or up to 30 pins

Most likely you will find a 20pin CH340 chip on it which is the USB/serial communication chip to talk to your PC.
If it is a FTDI chip - this comes with 30 pins and normally, given that it is no clone, should work out of the box when the IDE was installed.

Let’s assume it is a CH340 chip (if not, tell us, what name you found on the chip).
Then you will find the latest driver here.
Although it is a Chinese site, you can trust it :). I never had any issues with it.

Install the driver on your PC; open device manager and then connect the Nano (can still be out of the kit). A new device should be detected and a COM port assigned to it.

Then you can place the Nano back in the socket of the Jr kit and can start with experimenting. If not - then you should first have a look at your USB cable. Some of the cables cause problems.

If the cable is ok and it still doesn’t work come back and tell us, what happened when you connected the Nano to your PC and we might have to dig deeper.

One more thought before you follow my instructions in the previous post:
Did you select any board in the IDE -> you must select a Nano as board in the IDE tools! After that you might see the port if everything else was installed correctly.

I have a 30 pin header socket. I included a photo below.

I installed the IDE twice thinking there might have been an issue there. That did not change anything.

When I sent an email to support, it was recommended that I use the mini board. I have tried that and the Nano without success.

My processor is set to: ATmega328

Port: I can chose from three.

  1. /dev/cu.Bluetooth-incoming-port
  2. /dev/cu.Bluetooth-modem
  3. /dev/cu.SGH-T479-serialserver

What should the programmer setting be?

Right now it is USBtinyISP

This is the part that may have an incorrect setting.

When I try uploading a sample program I get this message:

Sketch uses 928 bytes (3%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00

I tried another computer, a mac book air and an it uploaded fine. I had tried 2 older macs (macbook pros) and win 7 pc and had issues.

Thank you again for your help.

Got it to work fine now.

  1. Congratulations that you eventually made it!
  2. to answer your question:

What should the programmer setting be?

Normally it should be set to "ArduinoISP" (NOT: "Arduino as ISP" or anything else when you are using a normal USB connection without any device between PC/Mac and the Nano.
3. Please mark this thread (you can edit your first post) as [SOLVED] in front of your headline, so that others can jump to a solved problem and hopefully learn from it.