Cannot Load Keywords.txt re-install processing

Hi All
I am sure this post must have com up before but i cannot find it anywhere.
Arduino was....... working perfectly happily and doing everything it should with no problems then i started getting the odd message 'Cannot Load Keywords.txt re-install processing' when i try to open an arduino file (*.ino) this happens on all projects. At first Arduino carried on opening, then later it came up with the message then closed again
First step uninstall and re install Arduino to the lates version....... same effect
Next i know Arduino uses Java so uninstall Jave and re install to latest version.... same effect
I found a post in a forum saying that there was a Keywords.txt bug with a copy of what it should look like so replace Keywords.txt ........ same effect, Arduino starts to open, the killer message then closes
I'm starting to run out of hair to pull out, as i said before i'm sure it must have been seen before, is there a guru out there that can help PLEEEEEEEESE
oh one other thing there is no problem with the project files, they open fine on a different pc
My system XP SE3

thanks for any replies

Hi, I've never seen that problem but files named keywords.txt are associated to libraries -- both the Arduino core libraries and the user-installed ones. Since you reinstalled the Arduino software I would look into the libraries directory in your sketchbook directory (the default location for your sketches and libraries, usually somewhere under your home directory). You may try to rename it and create an empty "libraries" directory, see if the sketch opens, then move the existing libraries into the new directory until you find the bad one.

Hi, Thanks for your input. the weird thing is that all of the files work ok on a different computer. The clue (i'm starting to think) might be in the bit that says 're install processing', i took it to mean base programmes i.e. Ardruino but after chasing down the processing bit the Arduino front end looks remarkably like the graphics programme called processing front end i'm wondering if the error message i'm seeing is a left over from the conversion from processing to Arduino.
i did try what you suggested, deleting and re creating the base folders but still get the same problem
weirder and weirder...... got to be something simple, looks too complicated not to be

Hi, I just got the same error (intentionally) by deleting the file libraries.txt under the Arduino program directory (on a Mac is /Contents/Resources/Java/lib, on Windows I believe that ‘lib’ is just under the arduino root directory). So I would reinstall the Arduino IDE one more time (and check that any arduino-related paths, such as those used by the “Open/Open with” commands, point to the new installation).

I have the same issue.
I was using 1.0.5 and installed the LEDControl library - copied it into the library folder in usr/share/arduino/libraries. I'm running Ubuntu 12.04 LTS
Suddenly I get this error.
So I unistalled and reinstalled- no change.
I've installed processing 1.5.1 successfully and unistalled and reinstalled the IDE (arduino and arduino-core) both from the terminal and tried using synaptic. No different.
Interestingly I can (and have) installed and run the IDE using the "Complete Numpties Guide" but this runs it from a desktop folder- so I can't pin it to the startbar annoyingly. But it does prove that I can run it on this computer.
Any help would be appreciated. I have also tried reinstalling without this desktop version to ensure they don't clash- again no help



I am also having the same issue with a new Windows 7 Install. Was working fine. It seems it started getting this message after I installed the debounce library. I tried re-installing same issue, deleted all of the regedit entries related to Arduino. My work around was to install under Windows Virtual PC running Windows XP. Seems to be working fine even after installing the debounce library. I have tried from versions 1.0,1.0.5 and 1.5.2, same problem.

I have this working on another Windows 7 install. I recreated this issue on that install by renaming the keyboard.txt file in the /lib folder. I think someone else on this tread did the same thing.

I am at a loss on what else to try.

Anyone have any new ideas?

Rick Jones

I had changed the formatting of a keywords doc in libraries. Then i started getting this message. I just went back to the doc and changed the formatting back and now it works again. Mine was an AF motor library, changed the formatting of the text back to how it came(one line) and it works. Let me know if this helps. seems too simple......

Thanks for the reply.

I deleted the ...\Documents\Arduino\libraries\Bounce folder and re installed the Bounce library and that seemed to fix the issue. Maybe somehow the keyword.txt file got changed in the old install.

Rick Jones

I use windows based OS but this simple solution will work on most platforms.
If this case happens it is usually because you messed with the Arduino libraries at some point.

Option 1
Simply move all the suspected libraries (folders) to another location outside of the "libraries" folder.
Usually located at: *C:\Program Files (x86)\Arduino\libraries* ...
Run the Arduino program and see if this error returns.
Then move back one folder at a time and run Arduino each time to see if the error return.

Option 2
If you know the latest libraries installed then simply delete the keywords.txt file in each folder you suspect the problem in.

I got this message also.
Tried everything even manualy deleted all the folders (i think) after de-installing the software.
but the problem is still there after i install the software again.

I tried all versions i could find but none solved my problem.

Can anyone please help me ??

I use Windows 7 64bits.


Hi, everybody !

Just had the precise same problem just now, found the unresolved topic and found my own solution, thought I would share.

I must say as a foreword that I'm running wheezy, you windoz folks will have to adapt.
My problem arose from a change of home directory.

Here is the fix that worked for me:
Edit the file preferences.txt
Under Debian it was found in /home/yyy/.arduino/
Some links were left in absolute adressing and I had to manually change them to reflect the new state of affairs ...


Ciao a tutti

My installation is on Win 7, Arduino 1.58 solution is

remove preferences.txt

from this folder


change username with the username you use to log to the win 7

on linux it could be a permission issue.

sudo chown -R user:user /home/user/sketchbook/

solved for me.

I was having this same problem and I finally solved it by editing preferences.txt to correct the sketchbook path. The path in the file was pointing to an out of date Arduino folder in a documents folder on the wrong drive.

On Windows 7, using Arduino 1.6.1

  • Navigate to C:\Users[yourUserName]\AppData\Roaming\Arduino15 (you need to have hidden files and folders showing, see steps below)
  • Open preferences.txt
  • Locate the line starting with "sketchbook.path" (near the bottom in my file)
  • Make sure the path is correctly pointing to your current Arduino projects folder

Note: by default Windows will hide certain folders it doesn't want you to mess around with. To see the AppData folder and to be able to easily navigate to the Arduino15 folder:

  • Open you root drive (usually C) and browse to your user folder
  • Open the "Organize" menu from the toolbar at the top of the window
  • Open "Folder and Search Options"
  • Click the "View" tab
  • In the Advanced settings, click "Show hidden files, folders, and drives"

Hope that helps


I'm having this error with 1.6.5 under Windows 7 64bit which had been working fine, then this week it won't launch. Re-installed and that didn't fix it. Then found this thread.

Followed the suggestion above, but there's no preferences.txt file in my C:\Users[yourUserName]\AppData\Roaming\Arduino15

I copied the default version from C:\Program Files (x86)\Arduino\lib, uncommented the line starting sketchbook.path= and added the right path.

It's not working at this point, still giving the same error after the splash screen.

Any thoughts or tips on how to get it sorted?


That was richly bizarre. Unlike the posters above, my issue wasn't with the preferences.txt file (which wasn't present, so couldn't edit nor delete it).

My issue was that two of my libraries have for some reason become encrypted. I found this when I renamed C:...\Documents\Arduino\libraries to C:...\Documents\Arduino\librariesOLD

Launching the IDE created a new libraries directory, and it completed loading. So I started moving my library folders over to the new empty subdirectory and noticed two of them were highlighted in green. Sure enough, that meant keywords.txt in both those is not readable. Copying either across to the libraries folder stopped the IDE from loading with that error.

Once the IDE loaded first time it creates the c:\users...\AppData\Roaming\Arduino15\preferences.txt file.

My issue is solved...aside from the mystery of how/why this encryption occurred which I'll tackle next.



I have had the same problem for months now ever since having to have Win 7 Pro "repaired" after malware infection (thanks, guys) - launch Arduino 1.6.4, splash, then "keyword.txt error, reinstall Arduino".
Before this, everything had been fine.
So, with nothing to lose, I started tinkering with any folder named "Libraries", by renaming, for example, "Libraries_".
Eventually, I changed one folder (renamed), and lo and behold, Arduino started up.
I think that somewhere in the repair of Win 7, some paths or folders ended up in the wrong place.
Nothing to do with "Roaming", didn't have to reinstall Arduino.
At the time of writing, this is just a piece of luck, nothing to do with expertise, but sometimes just messing about works.
The next step will be some housekeeping and getting all the libraries under one (working) roof.
To be honest, I had given up ever seeing 1.6.4 ever running again on this PC, and vowed never to run Arduino under Windows again.
Hope this helps