cannot load pro mini

New-bought pro-mini and Sparkfun FTDI Basic
Attempt to upload simple sketch,

</>

int aLed = 6;
int bLed = 5;
void setup() {
  pinMode(aLed, OUTPUT);
  pinMode(bLed, OUTPUT);
  digitalWrite(aLed, HIGH);
  }
void loop() {
  delay(2000);
  digitalWrite(bLed, HIGH);
  digitalWrite(aLed, LOW);
  delay(3000);
  digitalWrite(aLed, HIGH);
  delay(2000);
  digitalWrite(bLed, LOW);
  delay(2000);
  }

Error messages in response to “Upload”:

Arduino: 1.8.14 Hourly Build 2021/01/29 11:33 (Windows 10), Board: “Arduino Pro or Pro Mini, ATmega328P (5V, 16 MHz)”

Sketch uses 1012 bytes (3%) of program storage space. Maximum is 30720 bytes.

Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.

C:\Users\tom\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/bin/avrdude -CC:\Users\tom\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf -v -patmega328p -carduino -PCOM10 -b57600 -D -Uflash:w:C:\Users\tom\AppData\Local\Temp\arduino_build_430315/MINI-Pro_light_LEDs.ino.hex:i

avrdude: Version 6.3-20190619

Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is “C:\Users\tom\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf”

avrdude: can’t open config file “C:\Users\tom\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf”: No such file or directory

avrdude: error reading system wide configuration file “C:\Users\tom\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf”

avrdude: error reading system wide configuration file “C:\Users\tom\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf”

Invalid library found in C:\Users\tom\Documents\Arduino\libraries\arduino: Missing ‘author’ from library

Invalid library found in C:\Users\tom\Documents\Arduino\libraries\processing-latest: no headers files (.h) found in C:\Users\tom\Documents\Arduino\libraries\processing-latest

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

In the IDE “Board” is specified as pro mini, and I reconfig’d the port (Windows Device Manager) by checking “Set RTS on Close”

No preferences changed, except to get verbose messages for upload.

Have you followed sparkfun’s guide for these two devices on how to install drivers and configure the IDE to program the board ?

My advise: Start with a known, stable program.

Remove 1.8.14 from your pc. Download and use 1.8.13.

Hourly builds should only be used experienced users and developers. Yes, those versions should work but if you’re new to Arduino, you don’t need to deal with obscure, weird bugs. You use them when you need a new feature where the benefit is worth the risk. Beats me as to why they post them so prominently. Just my free 2 cents.

tmkane:
The folder user/tom/appdata does not exist on my w10/64 pc.

It does exist. It's hidden by default. You need to click the "View" button in Windows File Explorer, then check the box next to "Hidden Items".

Try following the instructions in this Help Center article:

Hi,
Are you using the .exe or .zip download of the IDE?

I ALWAYS use the zip and expand it to its own directory. Make a shortcut to the application file and place it on the desktop. DONE...

Tom... :slight_smile:

Drivers for FTDI are at www.ftdichip.com, if the drivers that come with the Arduino install are not working for you.

2.12.28.0 is what I see for an FTDI driver revision.

Hi,
You have got Tx to Rx and Rx to Tx crossover between the boards?

The LED occasionally flashing, probably once every seconds is the default code that is loaded on the controller.

Can you post a picture of your wiring setup please?

Thanks.. Tom... :slight_smile:

I only ever use one of the cheapies........
Work every time.
DTR > DTR
Tx > Rx
Rx > Tx
5V > 5V
Gnd > Gnd

Sort of basic question - are you sure you have the FTDI plugged in correctly? I have a different style connector and seems to me I plugged things backwards once or twice