Cannot open Arduino 1.8.16 in Linux Mint

I've been using 1.8.15 successfully for some time with no problems.
Tried today to upload a sketch to an esp32 Wemos Arduino which i did successfully yesterday only to find the esp32 options were missing from the board manager.
i tried to restore the urls but during the procedure the ide locked up.
I downloaded the arduino-1.8.16 linuxaarch64.tar.xz file and now have the desk top icon and the 1.8.16 folder in the downloads folder but nothing happens when i click on the icon. i am guessing that there is an old file somewhere that is corrupt but how do i locate all of the relevant old files and uninstall them?
Don

On Linux (mint) each installation is separate except the shared .Arduino folder and Arduino folder. I have 3 installations all under my user directory.

In order to gather more information that might help us to troubleshoot your problem, I'm going to ask you to run the Arduino IDE from the command line, then share the output.

Please do this:

  1. Start a terminal in the Arduino IDE installation folder
  2. Type ./arduino
  3. Press Enter.
  4. Wait for the Arduino IDE to finish starting, or failing to start.
  5. Switch back to the terminal window if the Arduino IDE window took the focus.
  6. Click and drag the mouse to select all the output in the terminal window.
  7. Press Ctrl+C. This will copy the selected text to the clipboard.
  8. Open a forum reply here by clicking the Reply button.
  9. Click the </> icon on the post composer toolbar. This will add the forum's code block markup (```) to your reply to make sure the output is correctly formatted.
    Code block
  10. Press Ctrl+V. This will paste the output into the code block.
  11. Move the cursor outside of the code block markup before you add any additional text to your reply.
  12. Click the Reply button to post the output.

don@DonHP:~/Downloads/arduino-1.8.16$ ./arduino
./arduino: line 35: /home/don/Downloads/arduino-1.8.16/java/bin/java: cannot execute binary file: Exec format error
don@DonHP:~/Downloads/arduino-1.8.16$ Preformatted text

"Exec format error" means you are using the wrong executable for your OS. If using a Raspberry Pi be sure to use the ARM Linux versions. Try the 32 bit version first. If it fails try the 64 bit version. If you are using an x86 (Intel/AMD) CPU, try the 32 bit version since you mentioned you tried the 64
bit version.

Thanks for the replies.
I did try the 32 bit version and the version 2 Beta but neither worked.
As the 64 bit download is the one I have successfully used I am wondering if this more a problem with Linux Mint than the Arduino IDE.
I am using a HP laptop with an Intel processor in this instance. I do have the Arduino IDE working fine on a Raspberry Pi and a Win10 PC.
Don

I went to the download site again and found arduino-1.8.16-linux64.tar.gz.(I don't know why I didn't see it before, I don't think it was there earlier) Downloaded and installed it but the result was that the flash screen came up and then disappeared.
After a few more searches I found references to .arduino15 causing similar problems.
"." files apparently are hidden files. After deleting it I can now boot up the arduino ide from the desktop icon.
i haven't tested it out fully yet but it looks ok so far.
Don