Cannot open Port on Uno Wifi Rev 2

Howdy,
I've got an Arduino Uno Wifi Rev 2 with an Atmel Mega4809. I tried to upload the Blink Example to make sure everything works but get this error. I've tried to chmod the port and adding the dialout to the group but that does not seem to fix the error. Any ideas? Thanks in advance.

Arduino: 1.8.16 (Linux), Board: "Arduino Uno WiFi Rev2, None (ATMEGA4809)"

Sketch uses 1510 bytes (3%) of program storage space. Maximum is 48640 bytes.
Global variables use 22 bytes (0%) of dynamic memory, leaving 6122 bytes for local variables. Maximum is 6144 bytes.
avrdude: usbdev_open(): cannot open device: Permission denied
avrdude: jtag3_open_common(): Did not find any device matching VID 0x03eb and PID list: 0x2145

Hi @thdunivan. You can try running this script that comes with the "Arduino megaAVR Boards" platform that provides the support for the Uno WiFi Rev2:

https://github.com/arduino/ArduinoCore-megaavr/blob/master/scripts/create_dfu_udev_rule

It is located on your computer at this path:

~/.arduino15/packages/arduino/hardware/megaavr/1.8.7/scripts/create_dfu_udev_rule

I ran the script but it resulted in a different error. I googled it but did not find much help. It is

avrdude: usbdev_open(): WARNING: failed to set configuration 1: Device or resource busy
avrdude: WARNING: invalid value for unused bits in fuse "fuse5", should be set to 1 according to datasheet
This behaviour is deprecated and will result in an error in future version
You probably want to use 0xcd instead of 0xc9 (double check with your datasheet first).

These are warnings, not errors. They are normal and expected. Please just ignore them. If you didn't get any errors then the upload was successful.

1 Like

Ok, Thank you for the help.

You are welcome. I'm glad if I was able to be of assistance. Enjoy!

1 Like