Cannot program fake Arduino pro mini :C

Hi guys... I have programmed an Arduino Pro Mini before, but I am having no luck with the one I got recently. The crystal oscillator says 8.0, so it must be the 8mhz version, as I have correctly selected. I am using a serial adaptor with the DTR pin. I have it connected corretly, that is Rx to Tx, etc. I have also tried disconnecting the DTR and pressing reset manually. The serial adaptor seems ok, gets normally recognized by Windows and works, as I have tested by shorting the Rx and Tx together and echoing some characters.

The Arduino environment sends the following command to AVRDude:

M:\Program Files\Arduno 1.6.11\hardware\tools\avr/bin/avrdude -CM:\Program Files\Arduno 1.6.11\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM14 -b57600 -D -Uflash:w:G:\AppData\Local\Temp\build809ceec5e21ecb4144db9bcd5f564f91.tmp/Blink.ino.hex:i

But the response is:

Using Port : COM14
Using Programmer : arduino
Overriding Baud Rate : 57600
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xd6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xd6
avrdude: stk500_recv(): programmer is not responding

(...)

I have actually tried re-burning the bootloader and although I succeeded (so the chip is okay!), it didn't fix my issues...

I have tried reading the fuse settings, but the fuses seem okay!

(this is using Arduino as ISP)

avrdude: AVR device initialized and ready to accept instructions

I was like:

C:\Users\thegoodhen>avrdude -P COM3 -b 19200 -c avrisp -p m328p -v

And the other dude Avrdude was like:

Reading | ################################################## | 100% 0.07s

avrdude: Device signature = 0x1e950f
avrdude: safemode: lfuse reads as FF
avrdude: safemode: hfuse reads as DA
avrdude: safemode: efuse reads as 5

avrdude: safemode: lfuse reads as FF
avrdude: safemode: hfuse reads as DA
avrdude: safemode: efuse reads as 5
avrdude: safemode: Fuses OK

avrdude done. Thank you.

Oh wait... is the baud rate correct? I have to check... Well anyway, if you have any idea why its behaving like this, please please do tell.

Edit: manually changing the baudrate to 19200 didn't help and plugging the thing directly in the PC, ommiting the extension cord also didn't. What now? :C

“Edit: manually changing the baudrate to 19200 didn’t help and plugging the thing directly in the PC, ommiting the extension cord also didn’t. What now? :C”

Try changing it to 38400. This works for mine using Minicore.