cannot program the chips after changing bootloader

I have tried everything on this page but nothing seems to work. I got a blank Atmega8 and try to load the bootloader using the simple parallel port programmer. I've tried to use avrdude, arduino bootloader (parallel port) tools and the ispprog as suggested.

Here's the result from Arduino bootloader tool: Atmel AVR ATmega8 is found. Writing lock bits ... Reinitializing device Atmel AVR ATmega8 is found.

Lock Bits set to 0xff Atmel AVR ATmega8 is found.

Fuse Low Byte set to 0xdf

Fuse High Byte set to 0xca Atmel AVR ATmega8 is found. Erasing device ... Reinitializing device Atmel AVR ATmega8 is found. Uploading: flash Verifying: flash flash error at address 0x1c00: file=0x12, mem=0xff flash error at address 0x1c01: file=0xc0, mem=0xff flash error at address 0x1c02: file=0x2b, mem=0xff flash error at address 0x1c03: file=0xc0, mem=0xff flash error at address 0x1c04: file=0x2a, mem=0xff ... Atmel AVR ATmega8 is found. Writing lock bits ... Reinitializing device Atmel AVR ATmega8 is found. Warning: lock bits write=0xCF read=0xFF

Lock Bits set to 0xcf

And the result from avrdude: avrdude: device not responding avrdude: initialization failed, rc=-1 Double Check connection and try again...

If I add the "-F" param to force uploading "Verification error, first mismatch at byte 0X0000 0xca !=0xff

result from ispprog: write error at address 00001C00 byte writte: 12byte read:FF

Any suggestions? I have another chip can ONLY be programmed on the Asuro robot with the cable connected the same way, but cannot be programmed on the adruino board (a friend helped me to modify the bootloader) ...and I can't overwrite the bootloader now to fix the problem...now I can't program my chips on Adruino board....

some help...

thanks...

Hamlet